summaryrefslogtreecommitdiffstats
path: root/test/CXX/except/except.spec/p4.cpp
diff options
context:
space:
mode:
Diffstat (limited to 'test/CXX/except/except.spec/p4.cpp')
-rw-r--r--test/CXX/except/except.spec/p4.cpp5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/CXX/except/except.spec/p4.cpp b/test/CXX/except/except.spec/p4.cpp
index 1bf7018..8d1b75f 100644
--- a/test/CXX/except/except.spec/p4.cpp
+++ b/test/CXX/except/except.spec/p4.cpp
@@ -34,3 +34,8 @@ template<typename T> struct U {
template<typename T> U<T>::~U() noexcept(true) {} // expected-error {{exception specification in declaration does not match previous declaration}}
template<typename T> void U<T>::operator delete(void*) noexcept(false) {} // expected-error {{exception specification in declaration does not match previous declaration}}
+
+
+// Make sure this restriction interacts properly with __attribute__((noreturn))
+void __attribute__ ((__noreturn__)) PR17110(int status) throw();
+void PR17110(int status) throw();
OpenPOWER on IntegriCloud