summaryrefslogtreecommitdiffstats
path: root/tar/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tar/test/CMakeLists.txt')
-rw-r--r--tar/test/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tar/test/CMakeLists.txt b/tar/test/CMakeLists.txt
index d776d78..98f49e2 100644
--- a/tar/test/CMakeLists.txt
+++ b/tar/test/CMakeLists.txt
@@ -5,12 +5,22 @@
############################################
IF(ENABLE_TAR AND ENABLE_TEST)
SET(bsdtar_test_SOURCES
+ ../../test_utils/test_utils.c
main.c
test.h
test_0.c
test_basic.c
test_copy.c
test_empty_mtree.c
+ test_extract_tar_Z.c
+ test_extract_tar_bz2.c
+ test_extract_tar_grz.c
+ test_extract_tar_gz.c
+ test_extract_tar_lrz.c
+ test_extract_tar_lz.c
+ test_extract_tar_lzma.c
+ test_extract_tar_lzo.c
+ test_extract_tar_xz.c
test_format_newc.c
test_help.c
test_option_C_upper.c
@@ -20,18 +30,29 @@ IF(ENABLE_TAR AND ENABLE_TEST)
test_option_T_upper.c
test_option_U_upper.c
test_option_X_upper.c
+ test_option_a.c
test_option_b.c
+ test_option_b64encode.c
test_option_exclude.c
test_option_gid_gname.c
+ test_option_grzip.c
+ test_option_j.c
test_option_k.c
test_option_keep_newer_files.c
+ test_option_lrzip.c
+ test_option_lzma.c
+ test_option_lzop.c
test_option_n.c
test_option_newer_than.c
test_option_nodump.c
+ test_option_older_than.c
test_option_q.c
test_option_r.c
test_option_s.c
test_option_uid_uname.c
+ test_option_uuencode.c
+ test_option_xz.c
+ test_option_z.c
test_patterns.c
test_print_longpath.c
test_stdio.c
@@ -68,6 +89,8 @@ IF(ENABLE_TAR AND ENABLE_TEST)
ENDMACRO (DEFINE_TEST _testname)
INCLUDE(${CMAKE_CURRENT_BINARY_DIR}/list.h)
+ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
+ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/test_utils)
# Experimental new test handling
ADD_CUSTOM_TARGET(run_bsdtar_test
OpenPOWER on IntegriCloud