summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/python_api/value_var_update
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/python_api/value_var_update')
-rw-r--r--packages/Python/lldbsuite/test/python_api/value_var_update/Makefile8
-rw-r--r--packages/Python/lldbsuite/test/python_api/value_var_update/TestValueVarUpdate.py59
-rw-r--r--packages/Python/lldbsuite/test/python_api/value_var_update/main.c15
3 files changed, 82 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/python_api/value_var_update/Makefile b/packages/Python/lldbsuite/test/python_api/value_var_update/Makefile
new file mode 100644
index 0000000..4b0e581
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/value_var_update/Makefile
@@ -0,0 +1,8 @@
+LEVEL = ../../make
+
+C_SOURCES := main.c
+CFLAGS_EXTRAS += -std=c99
+# See TestHelloWorld.py, which specifies the executable name with a dictionary.
+EXE := hello_world
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/python_api/value_var_update/TestValueVarUpdate.py b/packages/Python/lldbsuite/test/python_api/value_var_update/TestValueVarUpdate.py
new file mode 100644
index 0000000..251bbcf
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/value_var_update/TestValueVarUpdate.py
@@ -0,0 +1,59 @@
+"""Test SBValue::GetValueDidChange"""
+
+from __future__ import print_function
+
+
+
+import os, sys, time
+import lldb
+import time
+from lldbsuite.test.lldbtest import *
+
+class HelloWorldTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Get the full path to our executable to be attached/debugged.
+ self.exe = os.path.join(os.getcwd(), self.testMethodName)
+ self.d = {'EXE': self.testMethodName}
+
+ @add_test_categories(['pyapi'])
+ def test_with_process_launch_api(self):
+ """Test SBValue::GetValueDidChange"""
+ self.build(dictionary=self.d)
+ self.setTearDownCleanup(dictionary=self.d)
+ target = self.dbg.CreateTarget(self.exe)
+
+ breakpoint = target.BreakpointCreateBySourceRegex("break here", lldb.SBFileSpec("main.c"))
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ i = self.frame().FindVariable("i")
+ i_val = i.GetValueAsUnsigned(0)
+ c = self.frame().FindVariable("c")
+
+ # Update any values from the SBValue objects so we can ask them if they changed after a continue
+ i.GetValueDidChange()
+ c.GetChildAtIndex(1).GetValueDidChange()
+ c.GetChildAtIndex(0).GetChildAtIndex(0).GetValueDidChange()
+
+ if self.TraceOn(): self.runCmd("frame variable")
+
+ self.runCmd("continue")
+
+ if self.TraceOn(): self.runCmd("frame variable")
+
+ self.assertTrue(i_val != i.GetValueAsUnsigned(0), "GetValue() is saying a lie")
+ self.assertTrue(i.GetValueDidChange(), "GetValueDidChange() is saying a lie")
+
+ # Check complex type
+ self.assertTrue(c.GetChildAtIndex(0).GetChildAtIndex(0).GetValueDidChange() and
+ not c.GetChildAtIndex(1).GetValueDidChange(), "GetValueDidChange() is saying a lie")
diff --git a/packages/Python/lldbsuite/test/python_api/value_var_update/main.c b/packages/Python/lldbsuite/test/python_api/value_var_update/main.c
new file mode 100644
index 0000000..9ffca5c
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/value_var_update/main.c
@@ -0,0 +1,15 @@
+struct complex_type {
+ struct { long l; } inner;
+ struct complex_type *complex_ptr;
+};
+
+int main() {
+ int i = 0;
+ struct complex_type c = { { 1L }, &c };
+ for (int j = 3; j < 20; j++)
+ {
+ c.inner.l += (i += j);
+ i = i - 1; // break here
+ }
+ return i;
+}
OpenPOWER on IntegriCloud