summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/python_api/signals
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/python_api/signals')
-rw-r--r--packages/Python/lldbsuite/test/python_api/signals/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/python_api/signals/TestSignalsAPI.py47
-rw-r--r--packages/Python/lldbsuite/test/python_api/signals/main.cpp28
3 files changed, 80 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/python_api/signals/Makefile b/packages/Python/lldbsuite/test/python_api/signals/Makefile
new file mode 100644
index 0000000..8a7102e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/signals/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/python_api/signals/TestSignalsAPI.py b/packages/Python/lldbsuite/test/python_api/signals/TestSignalsAPI.py
new file mode 100644
index 0000000..9825c553
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/signals/TestSignalsAPI.py
@@ -0,0 +1,47 @@
+"""
+Test SBProcess APIs, including ReadMemory(), WriteMemory(), and others.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbutil import get_stopped_thread, state_type_to_str
+from lldbsuite.test.lldbtest import *
+
+class SignalsAPITestCase(TestBase):
+ mydir = TestBase.compute_mydir(__file__)
+
+ @add_test_categories(['pyapi'])
+ @expectedFlakeyLinux # this test fails 1/100 dosep runs
+ @skipIfWindows # Windows doesn't have signals
+ def test_ignore_signal(self):
+ """Test Python SBUnixSignals.Suppress/Stop/Notify() API."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ line = line_number("main.cpp", "// Set break point at this line and setup signal ignores.")
+ breakpoint = target.BreakpointCreateByLocation("main.cpp", line)
+ self.assertTrue(breakpoint, VALID_BREAKPOINT)
+
+ # Launch the process, and do not stop at the entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+
+ thread = get_stopped_thread(process, lldb.eStopReasonBreakpoint)
+ self.assertTrue(thread.IsValid(), "There should be a thread stopped due to breakpoint")
+
+ unix_signals = process.GetUnixSignals()
+ sigint = unix_signals.GetSignalNumberFromName("SIGINT")
+ unix_signals.SetShouldSuppress(sigint, True)
+ unix_signals.SetShouldStop(sigint, False)
+ unix_signals.SetShouldNotify(sigint, False)
+
+ process.Continue()
+ self.assertTrue(process.state == lldb.eStateExited, "The process should have exited")
+ self.assertTrue(process.GetExitStatus() == 0, "The process should have returned 0")
diff --git a/packages/Python/lldbsuite/test/python_api/signals/main.cpp b/packages/Python/lldbsuite/test/python_api/signals/main.cpp
new file mode 100644
index 0000000..81924f4
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/signals/main.cpp
@@ -0,0 +1,28 @@
+//===-- main.c --------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+#include <stdio.h>
+#include <sys/types.h>
+#if defined(_WIN32)
+#include <windows.h>
+#else
+#include <unistd.h>
+#include <signal.h>
+#endif
+
+// This simple program is to test the lldb Python API related to process.
+
+int main (int argc, char const *argv[])
+{
+#if defined(_WIN32)
+ ::ExitProcess(1);
+#else
+ kill(getpid(), SIGINT); // Set break point at this line and setup signal ignores.
+#endif
+ return 0;
+}
OpenPOWER on IntegriCloud