summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/lldbinline.py
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/lldbinline.py')
-rw-r--r--packages/Python/lldbsuite/test/lldbinline.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/packages/Python/lldbsuite/test/lldbinline.py b/packages/Python/lldbsuite/test/lldbinline.py
index 691a3fb..abde6e7 100644
--- a/packages/Python/lldbsuite/test/lldbinline.py
+++ b/packages/Python/lldbsuite/test/lldbinline.py
@@ -3,7 +3,6 @@ from __future__ import absolute_import
# System modules
import os
-import sys
# Third-party modules
@@ -23,6 +22,7 @@ def source_type(filename):
'.mm' : 'OBJCXX_SOURCES'
}.get(extension, None)
+
class CommandParser:
def __init__(self):
self.breakpoints = []
@@ -34,7 +34,7 @@ class CommandParser:
new_breakpoint = True
if len(parts) == 2:
- command = parts[1].strip() # take off whitespace
+ command = parts[1].strip() # take off whitespace
new_breakpoint = parts[0].strip() != ""
return (command, new_breakpoint)
@@ -85,7 +85,7 @@ class InlineTest(TestBase):
return "-N dwarf %s" % (self.mydir)
else:
return "-N dsym %s" % (self.mydir)
-
+
def BuildMakefile(self):
if os.path.exists("Makefile"):
return
@@ -116,11 +116,11 @@ class InlineTest(TestBase):
if ('CXX_SOURCES' in list(categories.keys())):
makefile.write("CXXFLAGS += -std=c++11\n")
+ makefile.write("\ncleanup:\n\trm -f Makefile *.d\n\n")
makefile.write("include $(LEVEL)/Makefile.rules\n")
makefile.flush()
makefile.close()
-
@skipUnlessDarwin
def __test_with_dsym(self):
self.using_dsym = True
OpenPOWER on IntegriCloud