summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/lang/c/tls_globals
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/lang/c/tls_globals')
-rw-r--r--packages/Python/lldbsuite/test/lang/c/tls_globals/Makefile11
-rw-r--r--packages/Python/lldbsuite/test/lang/c/tls_globals/TestTlsGlobals.py75
-rw-r--r--packages/Python/lldbsuite/test/lang/c/tls_globals/a.c18
-rw-r--r--packages/Python/lldbsuite/test/lang/c/tls_globals/main.c36
4 files changed, 140 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/lang/c/tls_globals/Makefile b/packages/Python/lldbsuite/test/lang/c/tls_globals/Makefile
new file mode 100644
index 0000000..90affed
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/c/tls_globals/Makefile
@@ -0,0 +1,11 @@
+LEVEL = ../../../make
+
+C_SOURCES := main.c
+CFLAGS_EXTRAS += -fPIC
+
+DYLIB_NAME := a
+DYLIB_C_SOURCES := a.c
+
+ENABLE_THREADS := YES
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/lang/c/tls_globals/TestTlsGlobals.py b/packages/Python/lldbsuite/test/lang/c/tls_globals/TestTlsGlobals.py
new file mode 100644
index 0000000..0d9e22e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/c/tls_globals/TestTlsGlobals.py
@@ -0,0 +1,75 @@
+"""Test that thread-local storage can be read correctly."""
+
+from __future__ import print_function
+
+
+
+import unittest2
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class TlsGlobalTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ TestBase.setUp(self)
+
+ if self.getPlatform() == "freebsd" or self.getPlatform() == "linux":
+ # LD_LIBRARY_PATH must be set so the shared libraries are found on startup
+ if "LD_LIBRARY_PATH" in os.environ:
+ self.runCmd("settings set target.env-vars " + self.dylibPath + "=" + os.environ["LD_LIBRARY_PATH"] + ":" + os.getcwd())
+ else:
+ self.runCmd("settings set target.env-vars " + self.dylibPath + "=" + os.getcwd())
+ self.addTearDownHook(lambda: self.runCmd("settings remove target.env-vars " + self.dylibPath))
+
+ @unittest2.expectedFailure("rdar://7796742")
+ @skipIfWindows # TLS works differently on Windows, this would need to be implemented separately.
+ def test(self):
+ """Test thread-local storage."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ line1 = line_number('main.c', '// thread breakpoint')
+ lldbutil.run_break_set_by_file_and_line (self, "main.c", line1, num_expected_locations=1, loc_exact=True)
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.runCmd("process status", "Get process status")
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ # BUG: sometimes lldb doesn't change threads to the stopped thread.
+ # (unrelated to this test).
+ self.runCmd("thread select 2", "Change thread")
+
+ # Check that TLS evaluates correctly within the thread.
+ self.expect("expr var_static", VARIABLES_DISPLAYED_CORRECTLY,
+ patterns = ["\(int\) \$.* = 88"])
+ self.expect("expr var_shared", VARIABLES_DISPLAYED_CORRECTLY,
+ patterns = ["\(int\) \$.* = 66"])
+
+ # Continue on the main thread
+ line2 = line_number('main.c', '// main breakpoint')
+ lldbutil.run_break_set_by_file_and_line (self, "main.c", line2, num_expected_locations=1, loc_exact=True)
+ self.runCmd("continue", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.runCmd("process status", "Get process status")
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ # BUG: sometimes lldb doesn't change threads to the stopped thread.
+ # (unrelated to this test).
+ self.runCmd("thread select 1", "Change thread")
+
+ # Check that TLS evaluates correctly within the main thread.
+ self.expect("expr var_static", VARIABLES_DISPLAYED_CORRECTLY,
+ patterns = ["\(int\) \$.* = 44"])
+ self.expect("expr var_shared", VARIABLES_DISPLAYED_CORRECTLY,
+ patterns = ["\(int\) \$.* = 33"])
diff --git a/packages/Python/lldbsuite/test/lang/c/tls_globals/a.c b/packages/Python/lldbsuite/test/lang/c/tls_globals/a.c
new file mode 100644
index 0000000..b9a8590
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/c/tls_globals/a.c
@@ -0,0 +1,18 @@
+//===-- a.c -----------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+#include <unistd.h>
+
+__thread int var_shared = 33;
+
+void shared_check()
+{
+ var_shared *= 2;
+ usleep(1); // shared thread breakpoint
+}
diff --git a/packages/Python/lldbsuite/test/lang/c/tls_globals/main.c b/packages/Python/lldbsuite/test/lang/c/tls_globals/main.c
new file mode 100644
index 0000000..cbe01b8
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/c/tls_globals/main.c
@@ -0,0 +1,36 @@
+//===-- main.c --------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+#include <stdio.h>
+#include <pthread.h>
+#include <unistd.h>
+
+void shared_check();
+
+// Create some TLS storage within the static executable.
+__thread int var_static = 44;
+
+void *fn_static(void *param)
+{
+ var_static *= 2;
+ shared_check();
+ usleep(1); // thread breakpoint
+ for(;;)
+ usleep(1);
+}
+
+int main (int argc, char const *argv[])
+{
+ pthread_t handle;
+ pthread_create(&handle, NULL, &fn_static, NULL);
+
+ for(;;)
+ usleep(1); // main breakpoint
+
+ return 0;
+}
OpenPOWER on IntegriCloud