summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/value_md5_crash
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/value_md5_crash')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/value_md5_crash/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/functionalities/value_md5_crash/TestValueMD5Crash.py52
-rw-r--r--packages/Python/lldbsuite/test/functionalities/value_md5_crash/main.cpp29
3 files changed, 86 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/value_md5_crash/Makefile b/packages/Python/lldbsuite/test/functionalities/value_md5_crash/Makefile
new file mode 100644
index 0000000..8a7102e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/value_md5_crash/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/value_md5_crash/TestValueMD5Crash.py b/packages/Python/lldbsuite/test/functionalities/value_md5_crash/TestValueMD5Crash.py
new file mode 100644
index 0000000..763ecc9
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/value_md5_crash/TestValueMD5Crash.py
@@ -0,0 +1,52 @@
+"""
+Verify that the hash computing logic for ValueObject's values can't crash us.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class ValueMD5CrashTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break at.
+ self.line = line_number('main.cpp', '// break here')
+
+ @expectedFailureWindows("llvm.org/pr24663")
+ def test_with_run_command(self):
+ """Verify that the hash computing logic for ValueObject's values can't crash us."""
+ self.build()
+ self.runCmd("file a.out", CURRENT_EXECUTABLE_SET)
+
+ lldbutil.run_break_set_by_file_and_line (self, "main.cpp", self.line, num_expected_locations=1, loc_exact=True)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ value = self.frame().FindVariable("a")
+ value.SetPreferDynamicValue(lldb.eDynamicCanRunTarget)
+
+ v = value.GetValue()
+ type_name = value.GetTypeName()
+ self.assertTrue(type_name == "B *", "a is a B*")
+
+ self.runCmd("next")
+ self.runCmd("process kill")
+
+ # now the process is dead, and value needs updating
+ v = value.GetValue()
+
+ # if we are here, instead of crashed, the test succeeded
diff --git a/packages/Python/lldbsuite/test/functionalities/value_md5_crash/main.cpp b/packages/Python/lldbsuite/test/functionalities/value_md5_crash/main.cpp
new file mode 100644
index 0000000..ba596b8
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/value_md5_crash/main.cpp
@@ -0,0 +1,29 @@
+//===-- main.cpp ------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+class A {
+public:
+ virtual int foo() { return 1; }
+ virtual ~A () = default;
+ A() = default;
+};
+
+class B : public A {
+public:
+ virtual int foo() { return 2; }
+ virtual ~B () = default;
+ B() = default;
+};
+
+int main() {
+ A* a = new B();
+ a->foo(); // break here
+ return 0; // break here
+}
+
OpenPOWER on IntegriCloud