summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/recursion
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/recursion')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/recursion/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/functionalities/recursion/TestValueObjectRecursion.py59
-rw-r--r--packages/Python/lldbsuite/test/functionalities/recursion/main.cpp41
3 files changed, 105 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/recursion/Makefile b/packages/Python/lldbsuite/test/functionalities/recursion/Makefile
new file mode 100644
index 0000000..8a7102e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/recursion/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/recursion/TestValueObjectRecursion.py b/packages/Python/lldbsuite/test/functionalities/recursion/TestValueObjectRecursion.py
new file mode 100644
index 0000000..fcb493b
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/recursion/TestValueObjectRecursion.py
@@ -0,0 +1,59 @@
+"""
+Test lldb data formatter subsystem.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class ValueObjectRecursionTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break at.
+ self.line = line_number('main.cpp', '// Set break point at this line.')
+
+ def test_with_run_command(self):
+ """Test that deeply nested ValueObjects still work."""
+ self.build()
+ self.runCmd("file a.out", CURRENT_EXECUTABLE_SET)
+
+ lldbutil.run_break_set_by_file_and_line (self, "main.cpp", self.line, num_expected_locations=1, loc_exact=True)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ # This is the function to remove the custom formats in order to have a
+ # clean slate for the next test case.
+ def cleanup():
+ self.runCmd('type format clear', check=False)
+ self.runCmd('type summary clear', check=False)
+
+ # Execute the cleanup function during test case tear down.
+ self.addTearDownHook(cleanup)
+
+ root = self.frame().FindVariable("root")
+ child = root.GetChildAtIndex(1)
+ if self.TraceOn():
+ print(root)
+ print(child)
+ for i in range(0,15000):
+ child = child.GetChildAtIndex(1)
+ if self.TraceOn():
+ print(child)
+ self.assertTrue(child.IsValid(),"could not retrieve the deep ValueObject")
+ self.assertTrue(child.GetChildAtIndex(0).IsValid(),"the deep ValueObject has no value")
+ self.assertTrue(child.GetChildAtIndex(0).GetValueAsUnsigned() != 0,"the deep ValueObject has a zero value")
+ self.assertTrue(child.GetChildAtIndex(1).GetValueAsUnsigned() != 0, "the deep ValueObject has no next")
diff --git a/packages/Python/lldbsuite/test/functionalities/recursion/main.cpp b/packages/Python/lldbsuite/test/functionalities/recursion/main.cpp
new file mode 100644
index 0000000..f75a7f8
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/recursion/main.cpp
@@ -0,0 +1,41 @@
+//===-- main.cpp ------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <stdint.h>
+
+struct node;
+struct node {
+ int value;
+ node* next;
+ node () : value(1),next(NULL) {}
+ node (int v) : value(v), next(NULL) {}
+};
+
+void make_tree(node* root, int count)
+{
+ int countdown=1;
+ if (!root)
+ return;
+ root->value = countdown;
+ while (count > 0)
+ {
+ root->next = new node(++countdown);
+ root = root->next;
+ count--;
+ }
+}
+
+int main (int argc, const char * argv[])
+{
+ node root(1);
+ make_tree(&root,25000);
+ return 0; // Set break point at this line.
+}
OpenPOWER on IntegriCloud