summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/nosucharch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/nosucharch')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/nosucharch/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/functionalities/nosucharch/TestNoSuchArch.py29
-rw-r--r--packages/Python/lldbsuite/test/functionalities/nosucharch/main.cpp3
3 files changed, 37 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/nosucharch/Makefile b/packages/Python/lldbsuite/test/functionalities/nosucharch/Makefile
new file mode 100644
index 0000000..8a7102e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/nosucharch/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/nosucharch/TestNoSuchArch.py b/packages/Python/lldbsuite/test/functionalities/nosucharch/TestNoSuchArch.py
new file mode 100644
index 0000000..7a6c98d
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/nosucharch/TestNoSuchArch.py
@@ -0,0 +1,29 @@
+"""
+Test that using a non-existent architecture name does not crash LLDB.
+"""
+from __future__ import print_function
+
+
+
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class NoSuchArchTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def test (self):
+ self.build()
+ exe = os.path.join (os.getcwd(), "a.out")
+
+ # Check that passing an invalid arch via the command-line fails but doesn't crash
+ self.expect("target crete --arch nothingtoseehere %s" % (exe), error=True)
+
+ # Check that passing an invalid arch via the SB API fails but doesn't crash
+ target = self.dbg.CreateTargetWithFileAndArch(exe,"nothingtoseehere")
+ self.assertFalse(target.IsValid(), "This target should not be valid")
+
+ # Now just create the target with the default arch and check it's fine
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target.IsValid(), "This target should now be valid")
diff --git a/packages/Python/lldbsuite/test/functionalities/nosucharch/main.cpp b/packages/Python/lldbsuite/test/functionalities/nosucharch/main.cpp
new file mode 100644
index 0000000..4cce7f6
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/nosucharch/main.cpp
@@ -0,0 +1,3 @@
+int main() {
+ return 0;
+}
OpenPOWER on IntegriCloud