summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/load_unload/hidden
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/load_unload/hidden')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/hidden/Makefile11
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/hidden/d.cpp21
2 files changed, 32 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/Makefile b/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/Makefile
new file mode 100644
index 0000000..f84d830
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/Makefile
@@ -0,0 +1,11 @@
+LEVEL := ../../../make
+
+LIB_PREFIX := loadunload_
+
+DYLIB_NAME := $(LIB_PREFIX)d
+DYLIB_CXX_SOURCES := d.cpp
+DYLIB_ONLY := YES
+
+CXXFLAGS += -fPIC
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/d.cpp b/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/d.cpp
new file mode 100644
index 0000000..6a7642c
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/d.cpp
@@ -0,0 +1,21 @@
+//===-- c.c -----------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+int d_init()
+{
+ return 456;
+}
+
+int d_global = d_init();
+
+int
+d_function ()
+{ // Find this line number within d_dunction().
+ return 12345;
+}
OpenPOWER on IntegriCloud