summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/TestDataFormatterRefPtrRecursion.py41
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/main.cpp21
3 files changed, 67 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/Makefile b/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/Makefile
new file mode 100644
index 0000000..314f1cb
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/TestDataFormatterRefPtrRecursion.py b/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/TestDataFormatterRefPtrRecursion.py
new file mode 100644
index 0000000..13b84e9
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/TestDataFormatterRefPtrRecursion.py
@@ -0,0 +1,41 @@
+"""
+Test that ValueObjectPrinter does not cause an infinite loop when a reference to a struct that contains a pointer to itself is printed.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class DataFormatterRefPtrRecursionTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break at.
+ self.line = line_number('main.cpp', '// Set break point at this line.')
+
+ def test_with_run_command(self):
+ """Test that ValueObjectPrinter does not cause an infinite loop when a reference to a struct that contains a pointer to itself is printed."""
+ self.build()
+ self.runCmd("file a.out", CURRENT_EXECUTABLE_SET)
+
+ lldbutil.run_break_set_by_file_and_line (self, "main.cpp", self.line, num_expected_locations=1, loc_exact=True)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ self.expect("frame variable foo", substrs = []);
+ self.expect("frame variable foo --ptr-depth=1", substrs = ['ID = 1']);
+ self.expect("frame variable foo --ptr-depth=2", substrs = ['ID = 1']);
+ self.expect("frame variable foo --ptr-depth=3", substrs = ['ID = 1']);
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/main.cpp b/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/main.cpp
new file mode 100644
index 0000000..4b576bd
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/refpointer-recursion/main.cpp
@@ -0,0 +1,21 @@
+int _ID = 0;
+
+class Foo {
+ public:
+ Foo *next;
+ int ID;
+
+ Foo () : next(0), ID(++_ID) {}
+};
+
+int evalFoo(Foo& foo)
+{
+ return foo.ID; // Set break point at this line.
+}
+
+int main() {
+ Foo f;
+ f.next = &f;
+ return evalFoo(f);
+}
+
OpenPOWER on IntegriCloud