summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/Makefile9
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/TestNSArraySynthetic.py67
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/main.m35
3 files changed, 111 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/Makefile b/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/Makefile
new file mode 100644
index 0000000..9f7fb1c
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/Makefile
@@ -0,0 +1,9 @@
+LEVEL = ../../../make
+
+OBJC_SOURCES := main.m
+
+CFLAGS_EXTRAS += -w
+
+include $(LEVEL)/Makefile.rules
+
+LDFLAGS += -framework Foundation
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/TestNSArraySynthetic.py b/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/TestNSArraySynthetic.py
new file mode 100644
index 0000000..a12f9c8
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/TestNSArraySynthetic.py
@@ -0,0 +1,67 @@
+"""
+Test lldb data formatter subsystem.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import datetime
+import lldbsuite.test.lldbutil as lldbutil
+
+class NSArraySyntheticTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break at.
+ self.line = line_number('main.m', '// Set break point at this line.')
+
+ @skipUnlessDarwin
+ def test_rdar11086338_with_run_command(self):
+ """Test that NSArray reports its synthetic children properly."""
+ self.build()
+ self.runCmd("file a.out", CURRENT_EXECUTABLE_SET)
+
+ lldbutil.run_break_set_by_file_and_line (self, "main.m", self.line, num_expected_locations=1, loc_exact=True)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ # This is the function to remove the custom formats in order to have a
+ # clean slate for the next test case.
+ def cleanup():
+ self.runCmd('type format clear', check=False)
+ self.runCmd('type summary clear', check=False)
+ self.runCmd('type synth clear', check=False)
+
+ # Execute the cleanup function during test case tear down.
+ self.addTearDownHook(cleanup)
+
+ # Now check that we are displaying Cocoa classes correctly
+ self.expect('frame variable arr',
+ substrs = ['@"6 elements"'])
+ self.expect('frame variable other_arr',
+ substrs = ['@"4 elements"'])
+ self.expect('frame variable arr --ptr-depth 1',
+ substrs = ['@"6 elements"','[0] = 0x','[1] = 0x','[2] = 0x','[3] = 0x','[4] = 0x','[5] = 0x'])
+ self.expect('frame variable other_arr --ptr-depth 1',
+ substrs = ['@"4 elements"','[0] = 0x','[1] = 0x','[2] = 0x','[3] = 0x'])
+ self.expect('frame variable arr --ptr-depth 1 -d no-run-target',
+ substrs = ['@"6 elements"','@"hello"','@"world"','@"this"','@"is"','@"me"','@"http://www.apple.com'])
+ self.expect('frame variable other_arr --ptr-depth 1 -d no-run-target',
+ substrs = ['@"4 elements"','(int)5','@"a string"','@"6 elements"'])
+ self.expect('frame variable other_arr --ptr-depth 2 -d no-run-target',
+ substrs = ['@"4 elements"','@"6 elements" {','@"hello"','@"world"','@"this"','@"is"','@"me"','@"http://www.apple.com'])
+
+ self.assertTrue(self.frame().FindVariable("arr").MightHaveChildren(), "arr says it does not have children!")
+ self.assertTrue(self.frame().FindVariable("other_arr").MightHaveChildren(), "arr says it does not have children!")
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/main.m b/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/main.m
new file mode 100644
index 0000000..1b4a6e0
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/nsarraysynth/main.m
@@ -0,0 +1,35 @@
+//===-- main.m ------------------------------------------------*- ObjC -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+#import <Foundation/Foundation.h>
+
+int main (int argc, const char * argv[])
+{
+
+ NSAutoreleasePool * pool = [[NSAutoreleasePool alloc] init];
+
+
+ NSMutableArray* arr = [[NSMutableArray alloc] init];
+ [arr addObject:@"hello"];
+ [arr addObject:@"world"];
+ [arr addObject:@"this"];
+ [arr addObject:@"is"];
+ [arr addObject:@"me"];
+ [arr addObject:[NSURL URLWithString:@"http://www.apple.com/"]];
+
+ NSDate *aDate = [NSDate distantFuture];
+ NSValue *aValue = [NSNumber numberWithInt:5];
+ NSString *aString = @"a string";
+
+ NSArray *other_arr = [NSArray arrayWithObjects:aDate, aValue, aString, arr, nil];
+
+ [pool drain];// Set break point at this line.
+ return 0;
+}
+
OpenPOWER on IntegriCloud