summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/TestFormatPropagation.py75
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/main.cpp13
3 files changed, 93 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/Makefile b/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/Makefile
new file mode 100644
index 0000000..314f1cb
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/TestFormatPropagation.py b/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/TestFormatPropagation.py
new file mode 100644
index 0000000..5cb7c82
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/TestFormatPropagation.py
@@ -0,0 +1,75 @@
+"""
+Check if changing Format on an SBValue correctly propagates that new format to children as it should
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class FormatPropagationTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break at.
+ self.line = line_number('main.cpp', '// Set break point at this line.')
+
+ # rdar://problem/14035604
+ def test_with_run_command(self):
+ """Check for an issue where capping does not work because the Target pointer appears to be changing behind our backs."""
+ self.build()
+ self.runCmd("file a.out", CURRENT_EXECUTABLE_SET)
+
+ lldbutil.run_break_set_by_file_and_line (self, "main.cpp", self.line, num_expected_locations=1, loc_exact=True)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ # This is the function to remove the custom formats in order to have a
+ # clean slate for the next test case.
+ def cleanup():
+ pass
+
+ # Execute the cleanup function during test case tear down.
+ self.addTearDownHook(cleanup)
+
+ # extract the parent and the children
+ frame = self.frame()
+ parent = self.frame().FindVariable("f")
+ self.assertTrue(parent != None and parent.IsValid(),"could not find f")
+ X = parent.GetChildMemberWithName("X")
+ self.assertTrue(X != None and X.IsValid(),"could not find X")
+ Y = parent.GetChildMemberWithName("Y")
+ self.assertTrue(Y != None and Y.IsValid(),"could not find Y")
+ # check their values now
+ self.assertTrue(X.GetValue() == "1", "X has an invalid value")
+ self.assertTrue(Y.GetValue() == "2", "Y has an invalid value")
+ # set the format on the parent
+ parent.SetFormat(lldb.eFormatHex)
+ self.assertTrue(X.GetValue() == "0x00000001", "X has not changed format")
+ self.assertTrue(Y.GetValue() == "0x00000002", "Y has not changed format")
+ # Step and check if the values make sense still
+ self.runCmd("next")
+ self.assertTrue(X.GetValue() == "0x00000004", "X has not become 4")
+ self.assertTrue(Y.GetValue() == "0x00000002", "Y has not stuck as hex")
+ # Check that children can still make their own choices
+ Y.SetFormat(lldb.eFormatDecimal)
+ self.assertTrue(X.GetValue() == "0x00000004", "X is still hex")
+ self.assertTrue(Y.GetValue() == "2", "Y has not been reset")
+ # Make a few more changes
+ parent.SetFormat(lldb.eFormatDefault)
+ X.SetFormat(lldb.eFormatHex)
+ Y.SetFormat(lldb.eFormatDefault)
+ self.assertTrue(X.GetValue() == "0x00000004", "X is not hex as it asked")
+ self.assertTrue(Y.GetValue() == "2", "Y is not defaulted")
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/main.cpp b/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/main.cpp
new file mode 100644
index 0000000..5822fbc
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/format-propagation/main.cpp
@@ -0,0 +1,13 @@
+struct foo
+{
+ int X;
+ int Y;
+ foo(int a, int b) : X(a), Y(b) {}
+};
+
+int main()
+{
+ foo f(1,2);
+ f.X = 4; // Set break point at this line.
+ return 0;
+}
OpenPOWER on IntegriCloud