summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/asan
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/asan')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/asan/Makefile6
-rw-r--r--packages/Python/lldbsuite/test/functionalities/asan/TestMemoryHistory.py103
-rw-r--r--packages/Python/lldbsuite/test/functionalities/asan/TestReportData.py79
-rw-r--r--packages/Python/lldbsuite/test/functionalities/asan/main.c34
4 files changed, 222 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/asan/Makefile b/packages/Python/lldbsuite/test/functionalities/asan/Makefile
new file mode 100644
index 0000000..26654a0
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/asan/Makefile
@@ -0,0 +1,6 @@
+LEVEL = ../../make
+
+C_SOURCES := main.c
+CFLAGS_EXTRAS := -fsanitize=address -g
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/asan/TestMemoryHistory.py b/packages/Python/lldbsuite/test/functionalities/asan/TestMemoryHistory.py
new file mode 100644
index 0000000..e92b967
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/asan/TestMemoryHistory.py
@@ -0,0 +1,103 @@
+"""
+Test that ASan memory history provider returns correct stack traces
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class AsanTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @expectedFailureLinux # non-core functionality, need to reenable and fix later (DES 2014.11.07)
+ @skipIfFreeBSD # llvm.org/pr21136 runtimes not yet available by default
+ @skipIfRemote
+ @skipUnlessCompilerRt
+ @expectedFailureDarwin
+ def test (self):
+ self.build ()
+ self.asan_tests ()
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ self.line_malloc = line_number('main.c', '// malloc line')
+ self.line_malloc2 = line_number('main.c', '// malloc2 line')
+ self.line_free = line_number('main.c', '// free line')
+ self.line_breakpoint = line_number('main.c', '// break line')
+
+ def asan_tests (self):
+ exe = os.path.join (os.getcwd(), "a.out")
+ self.expect("file " + exe, patterns = [ "Current executable set to .*a.out" ])
+
+ self.runCmd("breakpoint set -f main.c -l %d" % self.line_breakpoint)
+
+ # "memory history" command should not work without a process
+ self.expect("memory history 0",
+ error = True,
+ substrs = ["invalid process"])
+
+ self.runCmd("run")
+
+ # ASan will relaunch the process to insert its library.
+ self.expect("thread list", "Process should be stopped due to exec.",
+ substrs = ['stopped', 'stop reason = '])
+
+ self.runCmd("continue")
+
+ # the stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped', 'stop reason = breakpoint'])
+
+ # test that the ASan dylib is present
+ self.expect("image lookup -n __asan_describe_address", "__asan_describe_address should be present",
+ substrs = ['1 match found'])
+
+ # test the 'memory history' command
+ self.expect("memory history 'pointer'",
+ substrs = [
+ 'Memory allocated at', 'a.out`f1', 'main.c:%d' % self.line_malloc,
+ 'Memory deallocated at', 'a.out`f2', 'main.c:%d' % self.line_free])
+
+ # do the same using SB API
+ process = self.dbg.GetSelectedTarget().process
+ val = process.GetSelectedThread().GetSelectedFrame().EvaluateExpression("pointer")
+ addr = val.GetValueAsUnsigned()
+ threads = process.GetHistoryThreads(addr);
+ self.assertEqual(threads.GetSize(), 2)
+
+ history_thread = threads.GetThreadAtIndex(0)
+ self.assertTrue(history_thread.num_frames >= 2)
+ self.assertEqual(history_thread.frames[1].GetLineEntry().GetFileSpec().GetFilename(), "main.c")
+ self.assertEqual(history_thread.frames[1].GetLineEntry().GetLine(), self.line_free)
+
+ history_thread = threads.GetThreadAtIndex(1)
+ self.assertTrue(history_thread.num_frames >= 2)
+ self.assertEqual(history_thread.frames[1].GetLineEntry().GetFileSpec().GetFilename(), "main.c")
+ self.assertEqual(history_thread.frames[1].GetLineEntry().GetLine(), self.line_malloc)
+
+ # let's free the container (SBThreadCollection) and see if the SBThreads still live
+ threads = None
+ self.assertTrue(history_thread.num_frames >= 2)
+ self.assertEqual(history_thread.frames[1].GetLineEntry().GetFileSpec().GetFilename(), "main.c")
+ self.assertEqual(history_thread.frames[1].GetLineEntry().GetLine(), self.line_malloc)
+
+ # now let's break when an ASan report occurs and try the API then
+ self.runCmd("breakpoint set -n __asan_report_error")
+
+ self.runCmd("continue")
+
+ # the stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped', 'stop reason = breakpoint'])
+
+ # make sure the 'memory history' command still works even when we're generating a report now
+ self.expect("memory history 'another_pointer'",
+ substrs = [
+ 'Memory allocated at', 'a.out`f1', 'main.c:%d' % self.line_malloc2])
diff --git a/packages/Python/lldbsuite/test/functionalities/asan/TestReportData.py b/packages/Python/lldbsuite/test/functionalities/asan/TestReportData.py
new file mode 100644
index 0000000..4ef5878
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/asan/TestReportData.py
@@ -0,0 +1,79 @@
+"""
+Test the AddressSanitizer runtime support for report breakpoint and data extraction.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+import json
+
+class AsanTestReportDataCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @expectedFailureLinux # non-core functionality, need to reenable and fix later (DES 2014.11.07)
+ @skipIfFreeBSD # llvm.org/pr21136 runtimes not yet available by default
+ @skipIfRemote
+ @skipUnlessCompilerRt
+ @expectedFailureDarwin
+ def test(self):
+ self.build ()
+ self.asan_tests ()
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ self.line_malloc = line_number('main.c', '// malloc line')
+ self.line_malloc2 = line_number('main.c', '// malloc2 line')
+ self.line_free = line_number('main.c', '// free line')
+ self.line_breakpoint = line_number('main.c', '// break line')
+ self.line_crash = line_number('main.c', '// BOOM line')
+
+ def asan_tests (self):
+ exe = os.path.join (os.getcwd(), "a.out")
+ self.expect("file " + exe, patterns = [ "Current executable set to .*a.out" ])
+ self.runCmd("run")
+
+ # ASan will relaunch the process to insert its library.
+ self.expect("thread list", "Process should be stopped due to exec.",
+ substrs = ['stopped', 'stop reason = '])
+
+ # no extended info when we have no ASan report
+ thread = self.dbg.GetSelectedTarget().process.GetSelectedThread()
+ s = lldb.SBStream()
+ self.assertFalse(thread.GetStopReasonExtendedInfoAsJSON(s))
+
+ self.runCmd("continue")
+
+ self.expect("thread list", "Process should be stopped due to ASan report",
+ substrs = ['stopped', 'stop reason = Use of deallocated memory detected'])
+
+ self.assertEqual(self.dbg.GetSelectedTarget().process.GetSelectedThread().GetStopReason(), lldb.eStopReasonInstrumentation)
+
+ self.expect("bt", "The backtrace should show the crashing line",
+ substrs = ['main.c:%d' % self.line_crash])
+
+ self.expect("thread info -s", "The extended stop info should contain the ASan provided fields",
+ substrs = ["access_size", "access_type", "address", "pc", "description", "heap-use-after-free"])
+
+ output_lines = self.res.GetOutput().split('\n')
+ json_line = output_lines[2]
+ data = json.loads(json_line)
+ self.assertEqual(data["description"], "heap-use-after-free")
+ self.assertEqual(data["instrumentation_class"], "AddressSanitizer")
+ self.assertEqual(data["stop_type"], "fatal_error")
+
+ # now let's try the SB API
+ process = self.dbg.GetSelectedTarget().process
+ thread = process.GetSelectedThread()
+
+ s = lldb.SBStream()
+ self.assertTrue(thread.GetStopReasonExtendedInfoAsJSON(s))
+ s = s.GetData()
+ data2 = json.loads(s)
+ self.assertEqual(data, data2)
diff --git a/packages/Python/lldbsuite/test/functionalities/asan/main.c b/packages/Python/lldbsuite/test/functionalities/asan/main.c
new file mode 100644
index 0000000..fab760e4
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/asan/main.c
@@ -0,0 +1,34 @@
+//===-- main.c --------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+#include <stdio.h>
+#include <stdlib.h>
+
+char *pointer;
+char *another_pointer;
+
+void f1() {
+ pointer = malloc(10); // malloc line
+ another_pointer = malloc(20); // malloc2 line
+}
+
+void f2() {
+ free(pointer); // free line
+}
+
+int main (int argc, char const *argv[])
+{
+ f1();
+ f2();
+
+ printf("Hello world!\n"); // break line
+
+ pointer[0] = 'A'; // BOOM line
+
+ return 0;
+}
OpenPOWER on IntegriCloud