summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/expression_command/persistent_variables
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/expression_command/persistent_variables')
-rw-r--r--packages/Python/lldbsuite/test/expression_command/persistent_variables/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/expression_command/persistent_variables/TestPersistentVariables.py54
-rw-r--r--packages/Python/lldbsuite/test/expression_command/persistent_variables/main.c14
3 files changed, 73 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/expression_command/persistent_variables/Makefile b/packages/Python/lldbsuite/test/expression_command/persistent_variables/Makefile
new file mode 100644
index 0000000..0d70f25
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/persistent_variables/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+C_SOURCES := main.c
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/expression_command/persistent_variables/TestPersistentVariables.py b/packages/Python/lldbsuite/test/expression_command/persistent_variables/TestPersistentVariables.py
new file mode 100644
index 0000000..e148fcd
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/persistent_variables/TestPersistentVariables.py
@@ -0,0 +1,54 @@
+"""
+Test that lldb persistent variables works correctly.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+
+class PersistentVariablesTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def test_persistent_variables(self):
+ """Test that lldb persistent variables works correctly."""
+ self.build()
+
+ self.runCmd("file a.out", CURRENT_EXECUTABLE_SET)
+
+ self.runCmd("breakpoint set --source-pattern-regexp break")
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ self.runCmd("expression int $i = i")
+
+ self.expect("expression $i == i",
+ startstr = "(bool) $0 = true")
+
+ self.expect("expression $i + 1",
+ startstr = "(int) $1 = 6")
+
+ self.expect("expression $i + 3",
+ startstr = "(int) $2 = 8")
+
+ self.expect("expression $2 + $1",
+ startstr = "(int) $3 = 14")
+
+ self.expect("expression $3",
+ startstr = "(int) $3 = 14")
+
+ self.expect("expression $2",
+ startstr = "(int) $2 = 8")
+
+ self.expect("expression (int)-2",
+ startstr = "(int) $4 = -2")
+
+ self.expect("expression $4 > (int)31",
+ startstr = "(bool) $5 = false")
+
+ self.expect("expression (long)$4",
+ startstr = "(long) $6 = -2")
diff --git a/packages/Python/lldbsuite/test/expression_command/persistent_variables/main.c b/packages/Python/lldbsuite/test/expression_command/persistent_variables/main.c
new file mode 100644
index 0000000..fd41471
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/persistent_variables/main.c
@@ -0,0 +1,14 @@
+//===-- main.c --------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+int main (int argc, char const *argv[])
+{
+ int i = 5;
+ return 0; // Set breakpoint here
+}
OpenPOWER on IntegriCloud