summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/expression_command/expr-in-syscall
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/expression_command/expr-in-syscall')
-rw-r--r--packages/Python/lldbsuite/test/expression_command/expr-in-syscall/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/expression_command/expr-in-syscall/TestExpressionInSyscall.py82
-rw-r--r--packages/Python/lldbsuite/test/expression_command/expr-in-syscall/main.cpp12
3 files changed, 99 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/expression_command/expr-in-syscall/Makefile b/packages/Python/lldbsuite/test/expression_command/expr-in-syscall/Makefile
new file mode 100644
index 0000000..8a7102e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/expr-in-syscall/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/expression_command/expr-in-syscall/TestExpressionInSyscall.py b/packages/Python/lldbsuite/test/expression_command/expr-in-syscall/TestExpressionInSyscall.py
new file mode 100644
index 0000000..0430fa5
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/expr-in-syscall/TestExpressionInSyscall.py
@@ -0,0 +1,82 @@
+"""Test that we are able to evaluate expressions when the inferior is blocked in a syscall"""
+
+from __future__ import print_function
+
+
+
+import os
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+
+class ExprSyscallTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @expectedFailureWindows("llvm.org/pr21765") # Also getpid() is not a function on Windows anyway
+ def test_setpgid(self):
+ self.build()
+ self.expr_syscall()
+
+ def expr_syscall(self):
+ exe = os.path.join(os.getcwd(), 'a.out')
+
+ # Create a target by the debugger.
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ listener = lldb.SBListener("my listener")
+
+ # launch the inferior and don't wait for it to stop
+ self.dbg.SetAsync(True)
+ error = lldb.SBError()
+ process = target.Launch (listener,
+ None, # argv
+ None, # envp
+ None, # stdin_path
+ None, # stdout_path
+ None, # stderr_path
+ None, # working directory
+ 0, # launch flags
+ False, # Stop at entry
+ error) # error
+
+ self.assertTrue(process and process.IsValid(), PROCESS_IS_VALID)
+
+ event = lldb.SBEvent()
+
+ # Give the child enough time to reach the syscall,
+ # while clearing out all the pending events.
+ # The last WaitForEvent call will time out after 2 seconds.
+ while listener.WaitForEvent(2, event):
+ pass
+
+ # now the process should be running (blocked in the syscall)
+ self.assertEqual(process.GetState(), lldb.eStateRunning, "Process is running")
+
+ # send the process a signal
+ process.SendAsyncInterrupt()
+ while listener.WaitForEvent(2, event):
+ pass
+
+ # as a result the process should stop
+ # in all likelihood we have stopped in the middle of the sleep() syscall
+ self.assertEqual(process.GetState(), lldb.eStateStopped, PROCESS_STOPPED)
+ thread = process.GetSelectedThread()
+
+ # try evaluating a couple of expressions in this state
+ self.expect("expr release_flag = 1", substrs = [" = 1"])
+ self.expect("print (int)getpid()", substrs = [str(process.GetProcessID())])
+
+ # and run the process to completion
+ process.Continue()
+
+ # process all events
+ while listener.WaitForEvent(10, event):
+ new_state = lldb.SBProcess.GetStateFromEvent(event)
+ if new_state == lldb.eStateExited:
+ break
+
+ self.assertEqual(process.GetState(), lldb.eStateExited)
+ self.assertEqual(process.GetExitStatus(), 0)
diff --git a/packages/Python/lldbsuite/test/expression_command/expr-in-syscall/main.cpp b/packages/Python/lldbsuite/test/expression_command/expr-in-syscall/main.cpp
new file mode 100644
index 0000000..743b694
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/expr-in-syscall/main.cpp
@@ -0,0 +1,12 @@
+#include <chrono>
+#include <thread>
+
+volatile int release_flag = 0;
+
+int main(int argc, char const *argv[])
+{
+ while (! release_flag) // Wait for debugger to attach
+ std::this_thread::sleep_for(std::chrono::seconds(3));
+
+ return 0;
+}
OpenPOWER on IntegriCloud