summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/Makefile')
-rw-r--r--packages/Python/lldbsuite/test/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/Makefile b/packages/Python/lldbsuite/test/Makefile
new file mode 100644
index 0000000..4d08ef3
--- /dev/null
+++ b/packages/Python/lldbsuite/test/Makefile
@@ -0,0 +1,33 @@
+LLDB_LEVEL := ..
+include $(LLDB_LEVEL)/Makefile
+
+.PHONY: programs
+
+all:: check-local
+
+#----------------------------------------------------------------------
+# Make all of the test programs
+#----------------------------------------------------------------------
+programs:
+ find . -type d -depth 1 | xargs -J % find % \
+ -name Makefile \
+ -exec echo \; \
+ -exec echo make -f '{}' \; \
+ -execdir make \;
+
+#----------------------------------------------------------------------
+# Clean all of the test programs
+#----------------------------------------------------------------------
+clean::
+ find . -type d -depth 1 | xargs -J % find % \
+ -name Makefile \
+ -exec echo \; \
+ -exec echo make -f '{}' clean \; \
+ -execdir make clean \;
+
+#----------------------------------------------------------------------
+# Run the tests
+#----------------------------------------------------------------------
+check-local::
+ rm -rf lldb-test-traces
+ python $(PROJ_SRC_DIR)/dotest.py --executable $(ToolDir)/lldb -q -s lldb-test-traces -u CXXFLAGS -u CFLAGS -C $(subst ccache,,$(CC))
OpenPOWER on IntegriCloud