summaryrefslogtreecommitdiffstats
path: root/lib/Target/XCore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/XCore/CMakeLists.txt')
-rw-r--r--lib/Target/XCore/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/lib/Target/XCore/CMakeLists.txt b/lib/Target/XCore/CMakeLists.txt
index 38b35d7..9093de6 100644
--- a/lib/Target/XCore/CMakeLists.txt
+++ b/lib/Target/XCore/CMakeLists.txt
@@ -11,7 +11,8 @@ tablegen(XCoreGenCallingConv.inc -gen-callingconv)
tablegen(XCoreGenSubtarget.inc -gen-subtarget)
add_llvm_target(XCoreCodeGen
- XCoreFrameInfo.cpp
+ XCoreAsmPrinter.cpp
+ XCoreFrameLowering.cpp
XCoreInstrInfo.cpp
XCoreISelDAGToDAG.cpp
XCoreISelLowering.cpp
@@ -22,3 +23,5 @@ add_llvm_target(XCoreCodeGen
XCoreTargetObjectFile.cpp
XCoreSelectionDAGInfo.cpp
)
+
+add_subdirectory(TargetInfo)
OpenPOWER on IntegriCloud