summaryrefslogtreecommitdiffstats
path: root/crypto/heimdal/lib/auth/afskauthlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/heimdal/lib/auth/afskauthlib/Makefile.am')
-rw-r--r--crypto/heimdal/lib/auth/afskauthlib/Makefile.am25
1 files changed, 18 insertions, 7 deletions
diff --git a/crypto/heimdal/lib/auth/afskauthlib/Makefile.am b/crypto/heimdal/lib/auth/afskauthlib/Makefile.am
index 7dd6d52..d3e771c 100644
--- a/crypto/heimdal/lib/auth/afskauthlib/Makefile.am
+++ b/crypto/heimdal/lib/auth/afskauthlib/Makefile.am
@@ -1,4 +1,4 @@
-# $Id: Makefile.am,v 1.3 1999/04/08 12:35:33 joda Exp $
+# $Id: Makefile.am,v 1.5 2000/11/30 01:39:09 joda Exp $
include $(top_srcdir)/Makefile.am.common
@@ -17,22 +17,33 @@ OBJS = verify.o
CLEANFILES = $(foo_DATA) $(OBJS) so_locations
afskauthlib.so: $(OBJS)
- $(LD) -shared -o $@ $(LDFLAGS) $(OBJS) $(L)
+ $(LINK) -shared $(OBJS) $(L)
.c.o:
$(COMPILE) -c $<
if KRB4
-KAFS = $(top_builddir)/lib/kafs/.libs/libkafs.a
+KAFS = $(top_builddir)/lib/kafs/libkafs.la
endif
+if KRB5
L = \
$(KAFS) \
- $(top_builddir)/lib/krb5/.libs/libkrb5.a \
- $(top_builddir)/lib/asn1/.libs/libasn1.a \
+ $(top_builddir)/lib/krb5/libkrb5.la \
+ $(top_builddir)/lib/asn1/libasn1.la \
$(LIB_krb4) \
- $(top_builddir)/lib/des/.libs/libdes.a \
- $(top_builddir)/lib/roken/.libs/libroken.a \
+ $(top_builddir)/lib/des/libdes.la \
+ $(top_builddir)/lib/roken/libroken.la \
-lc
+else
+
+L = \
+ $(KAFS) \
+ $(LIB_krb4) \
+ $(top_builddir)/lib/des/libdes.la \
+ $(top_builddir)/lib/roken/libroken.la \
+ -lc
+endif
+
$(OBJS): $(top_builddir)/include/config.h
OpenPOWER on IntegriCloud