summaryrefslogtreecommitdiffstats
path: root/crypto/heimdal/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/heimdal/configure.in')
-rw-r--r--crypto/heimdal/configure.in113
1 files changed, 32 insertions, 81 deletions
diff --git a/crypto/heimdal/configure.in b/crypto/heimdal/configure.in
index 5072966..d07b658 100644
--- a/crypto/heimdal/configure.in
+++ b/crypto/heimdal/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION($Revision: 1.278 $)
-AC_PREREQ(2.14.-1.1)dnl 2.14a
-AC_INIT(heimdal, 0.3f, heimdal-bugs@pdc.kth.se)
+AC_REVISION($Revision: 1.304 $)
+AC_PREREQ(2.52)
+AC_INIT(heimdal, 0.4e, heimdal-bugs@pdc.kth.se)
AM_CONFIG_HEADER(include/config.h)
dnl Checks for programs.
@@ -9,7 +9,7 @@ AC_PROG_CC
AC_PROG_CPP
AC_PROG_CC_STDC
-AM_INIT_AUTOMAKE(heimdal,0.3f)
+AM_INIT_AUTOMAKE(heimdal,0.4e)
AC_PREFIX_DEFAULT(/usr/heimdal)
@@ -156,7 +156,6 @@ if test "$with_krb4" != "no"; then
LIBS="$save_LIBS"
CFLAGS="$save_CFLAGS"
LIB_kdb="-lkdb -lkrb"
- test_LIB_krb4="$LIB_krb4"
if test "$krb4_libdir"; then
LIB_krb4="-R $krb4_libdir $LIB_krb4"
LIB_kdb="-R $krb4_libdir -L$krb4_libdir $LIB_kdb"
@@ -187,29 +186,6 @@ fi
AC_SUBST(dpagaix_CFLAGS)
AC_SUBST(dpagaix_LDADD)
-
-AC_ARG_ENABLE(kaserver,
-[ --enable-kaserver if you want the KDC to try to emulate a kaserver])
-if test "$enable_kaserver" = yes; then
- AC_DEFINE(KASERVER, 1,
- [Define if you want to use the KDC as a kaserver.])
- if test "$with_krb4" = "no"; then
- AC_MSG_ERROR(kaserver requires krb4)
- exit 1
- fi
-fi
-
-AC_ARG_ENABLE(kaserver-db,
-[ --enable-kaserver-db if you want support for reading kaserver databases in hprop])
-if test "$enable_kaserver_db" = yes; then
- AC_DEFINE(KASERVER_DB, 1,
- [Define if you want support in hprop for reading kaserver databases])
- if test "$with_krb4" = "no"; then
- AC_MSG_ERROR(kaserver-db requires krb4)
- exit 1
- fi
-fi
-
otp=yes
AC_ARG_ENABLE(otp,
[ --disable-otp if you don't want OTP support],
@@ -274,20 +250,18 @@ AC_CHECK_HEADERS([\
bsdsetjmp.h \
crypt.h \
curses.h \
- dbm.h \
dirent.h \
dlfcn.h \
err.h \
errno.h \
fcntl.h \
fnmatch.h \
- gdbm/ndbm.h \
grp.h \
inttypes.h \
io.h \
+ libutil.h \
limits.h \
maillock.h \
- ndbm.h \
net/if.h \
netdb.h \
netinet/in.h \
@@ -302,7 +276,6 @@ AC_CHECK_HEADERS([\
pty.h \
pwd.h \
resolv.h \
- rpcsvc/dbm.h \
sac.h \
security/pam_modules.h \
sgtty.h \
@@ -344,6 +317,7 @@ AC_CHECK_HEADERS([\
sys/wait.h \
syslog.h \
term.h \
+ termcap.h \
termio.h \
termios.h \
time.h \
@@ -371,15 +345,17 @@ fi
AM_CONDITIONAL(have_err_h, test "$ac_cv_header_err_h" = yes)
AM_CONDITIONAL(have_fnmatch_h, test "$ac_cv_header_fnmatch_h" = yes)
-AC_KRB_IPV6
-
dnl Checks for libraries.
AC_FIND_FUNC(socket, socket)
AC_FIND_FUNC(gethostbyname, nsl)
AC_FIND_FUNC(syslog, syslog)
+AC_KRB_IPV6
+
AC_FIND_FUNC_NO_LIBS(logwtmp, util)
+AC_FIND_FUNC_NO_LIBS(logout, util)
+AC_FIND_FUNC_NO_LIBS(openpty, util)
AC_FIND_FUNC_NO_LIBS(tgetent, termcap ncurses curses)
AC_FIND_FUNC(gethostbyname2, inet6 ip6)
@@ -482,10 +458,6 @@ AC_FIND_FUNC_NO_LIBS(setsockopt,,
dnl Cray stuff
AC_CHECK_FUNCS(getudbnam setlim)
-rk_RETSIGTYPE
-
-rk_BROKEN_REALLOC
-
dnl AC_KRB_FUNC_GETCWD_BROKEN
dnl
@@ -544,47 +516,27 @@ AC_HAVE_STRUCT_FIELD(struct sockaddr, sa_len, [#include <sys/types.h>
#include <sys/socket.h>])
-AC_GROK_TYPES([int8_t int16_t int32_t int64_t \
- u_int8_t u_int16_t u_int32_t u_int64_t \
- uint8_t uint16_t uint32_t uint64_t])
-
-dnl
-dnl crypto functions tests
-dnl
-
-AC_CHECK_HEADERS([ \
- openssl/md4.h \
- openssl/md5.h \
- openssl/sha.h \
- openssl/des.h \
- openssl/rc4.h \
+AC_CHECK_TYPES([int8_t, int16_t, int32_t, int64_t,
+ u_int8_t, u_int16_t, u_int32_t, u_int64_t,
+ uint8_t, uint16_t, uint32_t, uint64_t],,,[
+#ifdef HAVE_INTTYPES_H
+#include <inttypes.h>
+#endif
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_BITYPES_H
+#include <sys/bitypes.h>
+#endif
+#ifdef HAVE_BIND_BITYPES_H
+#include <bind/bitypes.h>
+#endif
+#ifdef HAVE_NETINET_IN6_MACHTYPES_H
+#include <netinet/in6_machtypes.h>
+#endif
])
-AC_FIND_FUNC_NO_LIBS2(MD4_Init, crypto des, [], [], [], [$test_LIB_krb4])
-AC_FIND_FUNC_NO_LIBS2(MD5_Init, crypto des, [], [], [], [$test_LIB_krb4])
-AC_FIND_FUNC_NO_LIBS2(SHA1_Init, crypto des, [], [], [], [$test_LIB_krb4])
-AC_FIND_FUNC_NO_LIBS2(des_cbc_encrypt, crypto des, [], [], [], [$test_LIB_krb4])
-AC_FIND_FUNC_NO_LIBS2(RC4, crypto des, [], [], [], [$test_LIB_krb4])
-if test "$ac_cv_func_des_cbc_encrypt" = "yes" -a \
-"$ac_cv_func_MD4_Init" = "yes" -a \
-"$ac_cv_func_MD5_Init" = "yes" -a \
-"$ac_cv_func_SHA1_Init" = "yes" -a \
-"$ac_cv_func_RC4" = "yes"; then
- DIR_des=''
- LIB_des=''
- if test "$krb4_libdir" != ""; then
- LIB_des="-R $krb4_libdir -L$krb4_libdir"
- fi
- LIB_des="$LIB_des $ac_cv_funclib_MD4_Init"
- LIB_des_appl="$LIB_des"
-else
- DIR_des='des'
- LIB_des='$(top_builddir)/lib/des/libdes.la'
- LIB_des_appl="-ldes"
-fi
-AC_SUBST(DIR_des)
-AC_SUBST(LIB_des)
-AC_SUBST(LIB_des_appl)
+KRB_CRYPTO
KRB_READLINE
@@ -651,6 +603,9 @@ if test "$krb_cv_sys_streamspty" = yes; then
AC_DEFINE(STREAMSPTY, 1, [Define if you have streams ptys.])
fi
+dnl Some operating systems already have com_err and compile_et
+CHECK_COMPILE_ET
+
AC_AUTH_MODULES
dnl This is done by AC_OUTPUT but we need the result here.
@@ -674,10 +629,6 @@ AH_BOTTOM([#undef BINDIR
#undef LIBEXECDIR
#undef SBINDIR])
-if false; then
- # hack to shut up automake
- LIBOBJS="$LIBOBJS make-print-version.o"
-fi
LTLIBOBJS=`echo "$LIBOBJS" | sed 's/\.o/\.lo/g'`
AC_SUBST(LTLIBOBJS)
AC_CONFIG_FILES(Makefile \
OpenPOWER on IntegriCloud