summaryrefslogtreecommitdiffstats
path: root/contrib/openpam/t/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/openpam/t/Makefile.am')
-rw-r--r--contrib/openpam/t/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/contrib/openpam/t/Makefile.am b/contrib/openpam/t/Makefile.am
index a3f596d..8f9bf1f 100644
--- a/contrib/openpam/t/Makefile.am
+++ b/contrib/openpam/t/Makefile.am
@@ -1,16 +1,18 @@
-# $Id: Makefile.am 572 2012-04-05 15:41:44Z des $
+# $Id: Makefile.am 714 2013-08-19 15:30:21Z des $
-INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/lib
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/lib/libpam
noinst_HEADERS = t.h
# tests
-TESTS = t_openpam_readword t_openpam_readlinev
+TESTS =
+TESTS += t_openpam_readword
+TESTS += t_openpam_readlinev
check_PROGRAMS = $(TESTS)
# libt - common support code
check_LIBRARIES = libt.a
-libt_a_SOURCES = t_main.c
+libt_a_SOURCES = t_main.c t_file.c
# link with libpam and libt
-LDADD = libt.a $(top_builddir)/lib/libpam.la
+LDADD = libt.a $(top_builddir)/lib/libpam/libpam.la
OpenPOWER on IntegriCloud