summaryrefslogtreecommitdiffstats
path: root/contrib/openbsm/bin/auditdistd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/openbsm/bin/auditdistd/Makefile.am')
-rw-r--r--contrib/openbsm/bin/auditdistd/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/contrib/openbsm/bin/auditdistd/Makefile.am b/contrib/openbsm/bin/auditdistd/Makefile.am
new file mode 100644
index 0000000..88f2584
--- /dev/null
+++ b/contrib/openbsm/bin/auditdistd/Makefile.am
@@ -0,0 +1,33 @@
+##
+## $P4: //depot/projects/trustedbsd/openbsm/bin/auditdistd/Makefile.am#1 $
+##
+
+if USE_NATIVE_INCLUDES
+INCLUDES = -I$(top_builddir) -I$(top_srcdir)
+else
+INCLUDES = -I$(top_builddir) -I$(top_srcdir) -I$(top_srcdir)/sys
+endif
+
+sbin_PROGRAMS = auditdistd
+man5_MANS = auditdistd.conf.5
+man8_MANS = auditdistd.8
+CFLAGS = -Wno-format
+YFLAGS = -d
+auditdistd_LDFLAGS = -lcrypto
+
+auditdistd_SOURCES = \
+ auditdistd.c \
+ parse.y \
+ pjdlog.c \
+ proto.c \
+ proto_common.c \
+ proto_socketpair.c \
+ proto_tcp.c \
+ proto_tls.c \
+ proto_uds.c \
+ receiver.c \
+ sandbox.c \
+ sender.c \
+ subr.c \
+ token.l \
+ trail.c
OpenPOWER on IntegriCloud