summaryrefslogtreecommitdiffstats
path: root/contrib/ntp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/ntp/Makefile.am')
-rw-r--r--contrib/ntp/Makefile.am44
1 files changed, 31 insertions, 13 deletions
diff --git a/contrib/ntp/Makefile.am b/contrib/ntp/Makefile.am
index 40200e3..96918fc 100644
--- a/contrib/ntp/Makefile.am
+++ b/contrib/ntp/Makefile.am
@@ -1,24 +1,43 @@
#AUTOMAKE_OPTIONS = util/ansi2knr foreign dist-tarZ no-dependencies
-AUTOMAKE_OPTIONS = util/ansi2knr foreign
+AUTOMAKE_OPTIONS = util/ansi2knr foreign 1.5
SUBDIRS = \
scripts \
include \
ElectricFence \
- librsaref \
+ @ARLIB_DIR@ \
libntp \
libparse \
ntpd \
ntpdate \
ntpdc \
ntpq \
- ntptrace \
parseutil \
adjtimed \
clockstuff \
kernel \
+ @MAKE_SNTP@ \
util
+DIST_SUBDIRS= \
+ scripts \
+ include \
+ ElectricFence \
+ arlib \
+ libntp \
+ libparse \
+ ntpd \
+ ntpdate \
+ ntpdc \
+ ntpq \
+ parseutil \
+ adjtimed \
+ clockstuff \
+ kernel \
+ sntp \
+ util
+DISTCHECK_CONFIGURE_FLAGS= --with-arlib --with-sntp
+
EXTRA_DIST = \
COPYRIGHT \
ChangeLog \
@@ -26,15 +45,12 @@ EXTRA_DIST = \
NEWS \
NOTES.y2kfixes \
README.bk \
- README.cvs \
- README.des \
README.hackers \
+ README.patches \
README.refclocks \
- README.rsa \
README.versions \
TODO \
WHERE-TO-START \
- acconfig.h \
build \
config.guess \
config.h.in \
@@ -43,18 +59,18 @@ EXTRA_DIST = \
excludes \
flock-build \
install-sh \
- ntp_update \
readme.y2kfixes \
results.y2kfixes \
conf \
html \
+ libisc \
ports \
version
DISTCLEANFILES = .warning
#ETAGS_ARGS = $(srcdir)/Makefile.am $(srcdir)/configure.in
-ETAGS_ARGS = Makefile.am configure.in acconfig.h
+ETAGS_ARGS = Makefile.am configure.in
# HMS: make ports be the last directory...
# DIST_HOOK_DIRS = conf html scripts ports
@@ -62,23 +78,25 @@ ETAGS_ARGS = Makefile.am configure.in acconfig.h
# HMS: Keep .warning first, as that way it gets printed first.
BUILT_SOURCES = .warning $(srcdir)/COPYRIGHT $(srcdir)/version
-$(srcdir)/COPYRIGHT: html/copyright.htm
- ( echo "This file is automatically generated from html/copyright.htm" ; lynx -dump $(srcdir)/html/copyright.htm ) > $(srcdir)/COPYRIGHT.new && mv $(srcdir)/COPYRIGHT.new $(srcdir)/COPYRIGHT
+$(srcdir)/COPYRIGHT: $(srcdir)/html/copyright.html
+ ( echo "This file is automatically generated from html/copyright.html" ; lynx -dump $(srcdir)/html/copyright.html ) > $(srcdir)/COPYRIGHT.new && mv $(srcdir)/COPYRIGHT.new $(srcdir)/COPYRIGHT
# HMS: The next bit is still suboptimal. If bk is present but this NTP
# repo is not a bk repo, we'll get an error message from the prs command.
# Unfortunately, I haven't found the necessary magic to redirect this error
# output to /dev/null under ancient/unique shells like the one Ultrix uses.
-# We'll also get an error of srcdir or version is unwritable.
+# We'll also get an error if srcdir or version is unwritable.
$(srcdir)/version: FRC.version
-(bk version) >/dev/null 2>&1 && \
cd $(srcdir) && \
x=`bk -R prs -hr+ -nd:I: ChangeSet` && \
- case "$$x" in '') ;; *) echo $$x > version ;; esac
+ y=`cat version 2>/dev/null` || true && \
+ case "$$x" in ''|$$y) ;; *) echo $$x > version ;; esac
dist-hook:
@find $(distdir) -type d -name CVS -print | xargs rm -rf
@find $(distdir) -type d -name SCCS -print | xargs rm -rf
+ @chmod u+w $(distdir)/ports/winnt
@for i in `find $(distdir)/ports/winnt -type f -name '*.ds*' -print`; \
do chmod u+w $$i ; unix2dos $$i $$i; done
OpenPOWER on IntegriCloud