summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/tools/clang/lib/Sema/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/llvm/tools/clang/lib/Sema/CMakeLists.txt')
-rw-r--r--contrib/llvm/tools/clang/lib/Sema/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/contrib/llvm/tools/clang/lib/Sema/CMakeLists.txt b/contrib/llvm/tools/clang/lib/Sema/CMakeLists.txt
new file mode 100644
index 0000000..b54e8eb
--- /dev/null
+++ b/contrib/llvm/tools/clang/lib/Sema/CMakeLists.txt
@@ -0,0 +1,37 @@
+set(LLVM_NO_RTTI 1)
+
+add_clang_library(clangSema
+ AnalysisBasedWarnings.cpp
+ CodeCompleteConsumer.cpp
+ IdentifierResolver.cpp
+ JumpDiagnostics.cpp
+ ParseAST.cpp
+ Sema.cpp
+ SemaAccess.cpp
+ SemaAttr.cpp
+ SemaCXXCast.cpp
+ SemaCXXScopeSpec.cpp
+ SemaChecking.cpp
+ SemaCodeComplete.cpp
+ SemaDecl.cpp
+ SemaDeclAttr.cpp
+ SemaDeclCXX.cpp
+ SemaDeclObjC.cpp
+ SemaExceptionSpec.cpp
+ SemaExpr.cpp
+ SemaExprCXX.cpp
+ SemaExprObjC.cpp
+ SemaInit.cpp
+ SemaLookup.cpp
+ SemaObjCProperty.cpp
+ SemaOverload.cpp
+ SemaStmt.cpp
+ SemaTemplate.cpp
+ SemaTemplateDeduction.cpp
+ SemaTemplateInstantiate.cpp
+ SemaTemplateInstantiateDecl.cpp
+ SemaType.cpp
+ TargetAttributesSema.cpp
+ )
+
+add_dependencies(clangSema ClangDiagnosticSema ClangStmtNodes)
OpenPOWER on IntegriCloud