summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/tools/clang/lib/Lex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/llvm/tools/clang/lib/Lex/CMakeLists.txt')
-rw-r--r--contrib/llvm/tools/clang/lib/Lex/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/contrib/llvm/tools/clang/lib/Lex/CMakeLists.txt b/contrib/llvm/tools/clang/lib/Lex/CMakeLists.txt
new file mode 100644
index 0000000..632fbc6
--- /dev/null
+++ b/contrib/llvm/tools/clang/lib/Lex/CMakeLists.txt
@@ -0,0 +1,27 @@
+set(LLVM_NO_RTTI 1)
+
+# TODO: Add -maltivec when ARCH is PowerPC.
+
+add_clang_library(clangLex
+ HeaderMap.cpp
+ HeaderSearch.cpp
+ Lexer.cpp
+ LiteralSupport.cpp
+ MacroArgs.cpp
+ MacroInfo.cpp
+ PPCaching.cpp
+ PPDirectives.cpp
+ PPExpressions.cpp
+ PPLexerChange.cpp
+ PPMacroExpansion.cpp
+ PTHLexer.cpp
+ Pragma.cpp
+ PreprocessingRecord.cpp
+ Preprocessor.cpp
+ PreprocessorLexer.cpp
+ ScratchBuffer.cpp
+ TokenConcatenation.cpp
+ TokenLexer.cpp
+ )
+
+add_dependencies(clangLex ClangDiagnosticLex)
OpenPOWER on IntegriCloud