summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/tools/clang/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/llvm/tools/clang/lib/AST/CMakeLists.txt')
-rw-r--r--contrib/llvm/tools/clang/lib/AST/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/contrib/llvm/tools/clang/lib/AST/CMakeLists.txt b/contrib/llvm/tools/clang/lib/AST/CMakeLists.txt
new file mode 100644
index 0000000..bce3646
--- /dev/null
+++ b/contrib/llvm/tools/clang/lib/AST/CMakeLists.txt
@@ -0,0 +1,42 @@
+set(LLVM_NO_RTTI 1)
+
+add_clang_library(clangAST
+ APValue.cpp
+ ASTConsumer.cpp
+ ASTContext.cpp
+ ASTDiagnostic.cpp
+ ASTImporter.cpp
+ AttrImpl.cpp
+ CXXInheritance.cpp
+ Decl.cpp
+ DeclarationName.cpp
+ DeclBase.cpp
+ DeclCXX.cpp
+ DeclFriend.cpp
+ DeclGroup.cpp
+ DeclObjC.cpp
+ DeclPrinter.cpp
+ DeclTemplate.cpp
+ Expr.cpp
+ ExprConstant.cpp
+ ExprCXX.cpp
+ FullExpr.cpp
+ InheritViz.cpp
+ NestedNameSpecifier.cpp
+ ParentMap.cpp
+ RecordLayout.cpp
+ RecordLayoutBuilder.cpp
+ Stmt.cpp
+ StmtDumper.cpp
+ StmtIterator.cpp
+ StmtPrinter.cpp
+ StmtProfile.cpp
+ StmtViz.cpp
+ TemplateBase.cpp
+ TemplateName.cpp
+ Type.cpp
+ TypeLoc.cpp
+ TypePrinter.cpp
+ )
+
+add_dependencies(clangAST ClangDiagnosticAST ClangStmtNodes)
OpenPOWER on IntegriCloud