summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/tools/clang/examples/PrintFunctionNames/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/llvm/tools/clang/examples/PrintFunctionNames/CMakeLists.txt')
-rw-r--r--contrib/llvm/tools/clang/examples/PrintFunctionNames/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/contrib/llvm/tools/clang/examples/PrintFunctionNames/CMakeLists.txt b/contrib/llvm/tools/clang/examples/PrintFunctionNames/CMakeLists.txt
new file mode 100644
index 0000000..49dd22a
--- /dev/null
+++ b/contrib/llvm/tools/clang/examples/PrintFunctionNames/CMakeLists.txt
@@ -0,0 +1,26 @@
+set(SHARED_LIBRARY TRUE)
+
+set(LLVM_NO_RTTI 1)
+
+set(LLVM_USED_LIBS
+ clangIndex
+ clangFrontend
+ clangDriver
+ clangSema
+ clangAnalysis
+ clangAST
+ clangParse
+ clangLex
+ clangBasic)
+
+set( LLVM_LINK_COMPONENTS
+ bitreader
+ mc
+ core
+ )
+
+add_clang_library(PrintFunctionNames PrintFunctionNames.cpp)
+
+set_target_properties(PrintFunctionNames
+ PROPERTIES
+ LINKER_LANGUAGE CXX)
OpenPOWER on IntegriCloud