summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/lib/Target/WebAssembly/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/llvm/lib/Target/WebAssembly/CMakeLists.txt')
-rw-r--r--contrib/llvm/lib/Target/WebAssembly/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/contrib/llvm/lib/Target/WebAssembly/CMakeLists.txt b/contrib/llvm/lib/Target/WebAssembly/CMakeLists.txt
deleted file mode 100644
index df04c2a..0000000
--- a/contrib/llvm/lib/Target/WebAssembly/CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-set(LLVM_TARGET_DEFINITIONS WebAssembly.td)
-
-tablegen(LLVM WebAssemblyGenMCCodeEmitter.inc -gen-emitter)
-tablegen(LLVM WebAssemblyGenSubtargetInfo.inc -gen-subtarget)
-add_public_tablegen_target(WebAssemblyCommonTableGen)
-
-add_llvm_target(WebAssemblyCodeGen
- WebAssemblyFrameLowering.cpp
- WebAssemblyInstrInfo.cpp
- WebAssemblyISelDAGToDAG.cpp
- WebAssemblyISelLowering.cpp
- WebAssemblyMachineFunctionInfo.cpp
- WebAssemblyRegisterInfo.cpp
- WebAssemblySelectionDAGInfo.cpp
- WebAssemblySubtarget.cpp
- WebAssemblyTargetMachine.cpp
- WebAssemblyTargetTransformInfo.cpp
-)
-
-add_dependencies(LLVMWebAssemblyCodeGen intrinsics_gen)
-
-add_subdirectory(InstPrinter)
-add_subdirectory(TargetInfo)
-add_subdirectory(MCTargetDesc)
OpenPOWER on IntegriCloud