summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/lib/Target/Alpha/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/llvm/lib/Target/Alpha/CMakeLists.txt')
-rw-r--r--contrib/llvm/lib/Target/Alpha/CMakeLists.txt29
1 files changed, 0 insertions, 29 deletions
diff --git a/contrib/llvm/lib/Target/Alpha/CMakeLists.txt b/contrib/llvm/lib/Target/Alpha/CMakeLists.txt
deleted file mode 100644
index fbf7f3a..0000000
--- a/contrib/llvm/lib/Target/Alpha/CMakeLists.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-set(LLVM_TARGET_DEFINITIONS Alpha.td)
-
-tablegen(AlphaGenRegisterInfo.h.inc -gen-register-desc-header)
-tablegen(AlphaGenRegisterNames.inc -gen-register-enums)
-tablegen(AlphaGenRegisterInfo.inc -gen-register-desc)
-tablegen(AlphaGenInstrNames.inc -gen-instr-enums)
-tablegen(AlphaGenInstrInfo.inc -gen-instr-desc)
-tablegen(AlphaGenCodeEmitter.inc -gen-emitter)
-tablegen(AlphaGenAsmWriter.inc -gen-asm-writer)
-tablegen(AlphaGenDAGISel.inc -gen-dag-isel)
-tablegen(AlphaGenCallingConv.inc -gen-callingconv)
-tablegen(AlphaGenSubtarget.inc -gen-subtarget)
-
-add_llvm_target(AlphaCodeGen
- AlphaBranchSelector.cpp
- AlphaCodeEmitter.cpp
- AlphaInstrInfo.cpp
- AlphaISelDAGToDAG.cpp
- AlphaISelLowering.cpp
- AlphaJITInfo.cpp
- AlphaLLRP.cpp
- AlphaMCAsmInfo.cpp
- AlphaRegisterInfo.cpp
- AlphaSubtarget.cpp
- AlphaTargetMachine.cpp
- AlphaSelectionDAGInfo.cpp
- )
-
-target_link_libraries (LLVMAlphaCodeGen LLVMSelectionDAG)
OpenPOWER on IntegriCloud