summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/examples/ParallelJIT/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/llvm/examples/ParallelJIT/CMakeLists.txt')
-rw-r--r--contrib/llvm/examples/ParallelJIT/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/contrib/llvm/examples/ParallelJIT/CMakeLists.txt b/contrib/llvm/examples/ParallelJIT/CMakeLists.txt
new file mode 100644
index 0000000..fbdc6e5
--- /dev/null
+++ b/contrib/llvm/examples/ParallelJIT/CMakeLists.txt
@@ -0,0 +1,9 @@
+set(LLVM_LINK_COMPONENTS jit interpreter nativecodegen)
+
+add_llvm_example(ParallelJIT
+ ParallelJIT.cpp
+ )
+
+if(HAVE_LIBPTHREAD)
+ target_link_libraries(ParallelJIT pthread)
+endif(HAVE_LIBPTHREAD)
OpenPOWER on IntegriCloud