summaryrefslogtreecommitdiffstats
path: root/contrib/libxo/xohtml/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libxo/xohtml/Makefile.am')
-rw-r--r--contrib/libxo/xohtml/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/contrib/libxo/xohtml/Makefile.am b/contrib/libxo/xohtml/Makefile.am
new file mode 100644
index 0000000..49dffed
--- /dev/null
+++ b/contrib/libxo/xohtml/Makefile.am
@@ -0,0 +1,38 @@
+#
+# Copyright 2015, Juniper Networks, Inc.
+# All rights reserved.
+# This SOFTWARE is licensed under the LICENSE provided in the
+# ../Copyright file. By downloading, installing, copying, or otherwise
+# using the SOFTWARE, you agree to be bound by the terms of that
+# LICENSE.
+
+man_MANS = xohtml.1
+
+EXTERNAL_FILES = \
+ external/jquery.js \
+ external/jquery.qtip.css \
+ external/jquery.qtip.js
+
+INTERNAL_FILES = \
+ xohtml.js \
+ xohtml.css
+
+EXTRA_DIST = \
+ xohtml.1 \
+ xohtml.sh.in \
+ ${INTERNAL_FILES} \
+ ${EXTERNAL_FILES}
+
+install-exec-hook:
+ install xohtml.sh ${DESTDIR}${bindir}/xohtml
+ mkdir -p ${DESTDIR}${XO_SHAREDIR}/external
+ for file in ${INTERNAL_FILES}; do \
+ install ${srcdir}/$$file ${DESTDIR}${XO_SHAREDIR} ; done
+ for file in ${EXTERNAL_FILES}; do \
+ install ${srcdir}/$$file ${DESTDIR}${XO_SHAREDIR}/external ; done
+
+uninstall-hook:
+ for file in ${INTERNAL_FILES} ${EXTERNAL_FILES}; do \
+ rm ${DESTDIR}${XO_SHAREDIR}/$$file ; done
+ rmdir ${DESTDIR}${XO_SHAREDIR}/external
+ rm -f ${DESTDIR}${bindir}/xohtml
OpenPOWER on IntegriCloud