summaryrefslogtreecommitdiffstats
path: root/contrib/libxo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libxo/Makefile.am')
-rw-r--r--contrib/libxo/Makefile.am42
1 files changed, 41 insertions, 1 deletions
diff --git a/contrib/libxo/Makefile.am b/contrib/libxo/Makefile.am
index cb71d52..286bef9 100644
--- a/contrib/libxo/Makefile.am
+++ b/contrib/libxo/Makefile.am
@@ -38,7 +38,14 @@ GH_PAGES_DIR = gh-pages/
GH_PAGES_DIR_VER = gh-pages/${PACKAGE_VERSION}
PACKAGE_FILE = ${PACKAGE_TARNAME}-${PACKAGE_VERSION}.tar.gz
-upload: dist upload-docs
+XOHTML_FILES = \
+ ${top_srcdir}/xohtml/xohtml.css \
+ ${top_srcdir}/xohtml/xohtml.js \
+ ${top_srcdir}/xohtml/external/jquery.js \
+ ${top_srcdir}/xohtml/external/jquery.qtip.css \
+ ${top_srcdir}/xohtml/external/jquery.qtip.js
+
+upload: dist upload-docs upload-xohtml-files
@echo "Remember to run:"
@echo " gt tag ${PACKAGE_VERSION}"
@@ -56,6 +63,18 @@ upload-docs: docs
libxo-manual.html ${PACKAGE_VERSION} \
&& git push origin gh-pages ) ; true
+upload-xohtml-files:
+ @echo "Uploading xohtml files ... "
+ @-[ -d ${GH_PAGES_DIR} ] \
+ && echo "Updating xohtml files on gh-pages ..." \
+ && mkdir -p ${GH_PAGES_DIR_VER}/xohtml \
+ && cp ${XOHTML_FILES} ${GH_PAGES_DIR_VER}/xohtml \
+ && (cd ${GH_PAGES_DIR} \
+ && git add ${PACKAGE_VERSION}/xohtml \
+ && git commit -m 'new xohtml files' \
+ ${PACKAGE_VERSION}/xohtml \
+ && git push origin gh-pages ) ; true
+
pkgconfigdir=$(libdir)/pkgconfig
pkgconfig_DATA = packaging/${PACKAGE_NAME}.pc
@@ -100,4 +119,25 @@ ANALYZE_DIR = ~/trash/libxo
ANALYZE_CMD = scan-build-mp-3.6
analyze:
+ ${MAKE} clean
${ANALYZE_CMD} -o ${ANALYZE_DIR} ${MAKE}
+
+SANIFLAGS=-fno-omit-frame-pointer -g -O2
+
+sanitize-address:
+ ${MAKE} clean
+ ${MAKE} CFLAGS="-fsanitize=address ${SANIFLAGS}"
+ ${MAKE} install
+ ${MAKE} test
+
+sanitize-undefined:
+ ${MAKE} clean
+ ${MAKE} CFLAGS="-fsanitize=undefined ${SANIFLAGS}"
+ ${MAKE} install
+ ${MAKE} test
+
+sanitize-memory:
+ ${MAKE} clean
+ ${MAKE} CFLAGS="-fsanitize=memory ${SANIFLAGS}"
+ ${MAKE} install
+ ${MAKE} test
OpenPOWER on IntegriCloud