summaryrefslogtreecommitdiffstats
path: root/contrib/gcc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/gcc/configure.ac')
-rw-r--r--contrib/gcc/configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/contrib/gcc/configure.ac b/contrib/gcc/configure.ac
index b6c394c..fc29233 100644
--- a/contrib/gcc/configure.ac
+++ b/contrib/gcc/configure.ac
@@ -1729,7 +1729,8 @@ for f in $build_xm_file; do
esac
done
-# Define macro CROSS_COMPILE in compilation if this is a cross-compiler.
+# Define macro CROSS_DIRECTORY_STRUCTURE in compilation if this is a
+# cross-compiler which does not use the native headers and libraries.
# Also use all.cross instead of all.internal and adjust SYSTEM_HEADER_DIR.
CROSS= AC_SUBST(CROSS)
ALL=all.internal AC_SUBST(ALL)
@@ -1746,7 +1747,7 @@ fi
if test x$host != x$target
then
- CROSS="-DCROSS_COMPILE"
+ CROSS="-DCROSS_DIRECTORY_STRUCTURE"
ALL=all.cross
SYSTEM_HEADER_DIR=$build_system_header_dir
case "$host","$target" in
OpenPOWER on IntegriCloud