summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/tools/lldb-mi/target
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/tools/lldb-mi/target
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/tools/lldb-mi/target')
-rw-r--r--packages/Python/lldbsuite/test/tools/lldb-mi/target/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/tools/lldb-mi/target/TestMiTarget.py125
-rw-r--r--packages/Python/lldbsuite/test/tools/lldb-mi/target/test_attach.cpp21
3 files changed, 151 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/tools/lldb-mi/target/Makefile b/packages/Python/lldbsuite/test/tools/lldb-mi/target/Makefile
new file mode 100644
index 0000000..b2550fe
--- /dev/null
+++ b/packages/Python/lldbsuite/test/tools/lldb-mi/target/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../../make
+
+CXX_SOURCES := test_attach.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/tools/lldb-mi/target/TestMiTarget.py b/packages/Python/lldbsuite/test/tools/lldb-mi/target/TestMiTarget.py
new file mode 100644
index 0000000..73ef913
--- /dev/null
+++ b/packages/Python/lldbsuite/test/tools/lldb-mi/target/TestMiTarget.py
@@ -0,0 +1,125 @@
+"""
+Test lldb-mi -target-xxx commands.
+"""
+
+from __future__ import print_function
+
+
+
+import lldbmi_testcase
+from lldbsuite.test.lldbtest import *
+
+class MiTargetTestCase(lldbmi_testcase.MiTestCaseBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @skipIfWindows #llvm.org/pr24452: Get lldb-mi tests working on Windows
+ @skipIfFreeBSD # llvm.org/pr22411: Failure presumably due to known thread races
+ @skipIfLinux # cannot attach to process on linux
+ def test_lldbmi_target_attach_wait_for(self):
+ """Test that 'lldb-mi --interpreter' works for -target-attach -n <name> --waitfor."""
+
+ # Build target executable with unique name
+ exeName = self.testMethodName
+ d = {'EXE': exeName}
+ self.buildProgram("test_attach.cpp", exeName)
+ self.addTearDownCleanup(dictionary=d)
+
+ self.spawnLldbMi(args = None)
+
+ # Load executable
+ # FIXME: -file-exec-and-sybmols is not required for target attach, but the test will not pass without this
+ self.runCmd("-file-exec-and-symbols %s" % exeName)
+ self.expect("\^done")
+
+ # Set up attach
+ self.runCmd("-target-attach -n %s --waitfor" % exeName)
+ time.sleep(4) # Give attach time to setup
+
+ # Start target process
+ self.spawnSubprocess(os.path.join(os.path.dirname(__file__), exeName));
+ self.addTearDownHook(self.cleanupSubprocesses)
+ self.expect("\^done")
+
+ # Set breakpoint on printf
+ line = line_number('test_attach.cpp', '// BP_i++')
+ self.runCmd("-break-insert -f test_attach.cpp:%d" % line)
+ self.expect("\^done,bkpt={number=\"1\"")
+
+ # Continue to breakpoint
+ self.runCmd("-exec-continue")
+ self.expect("\*stopped,reason=\"breakpoint-hit\"")
+
+ # Detach
+ self.runCmd("-target-detach")
+ self.expect("\^done")
+
+ @skipIfWindows #llvm.org/pr24452: Get lldb-mi tests working on Windows
+ @skipIfFreeBSD # llvm.org/pr22411: Failure presumably due to known thread races
+ @skipIfLinux # cannot attach to process on linux
+ def test_lldbmi_target_attach_name(self):
+ """Test that 'lldb-mi --interpreter' works for -target-attach -n <name>."""
+
+ # Build target executable with unique name
+ exeName = self.testMethodName
+ d = {'EXE': exeName}
+ self.buildProgram("test_attach.cpp", exeName)
+ self.addTearDownCleanup(dictionary=d)
+
+ # Start target process
+ targetProcess = self.spawnSubprocess(os.path.join(os.path.dirname(__file__), exeName));
+ self.addTearDownHook(self.cleanupSubprocesses)
+
+ self.spawnLldbMi(args = None)
+
+ # Set up atatch
+ self.runCmd("-target-attach -n %s" % exeName)
+ self.expect("\^done")
+
+ # Set breakpoint on printf
+ line = line_number('test_attach.cpp', '// BP_i++')
+ self.runCmd("-break-insert -f test_attach.cpp:%d" % line)
+ self.expect("\^done,bkpt={number=\"1\"")
+
+ # Continue to breakpoint
+ self.runCmd("-exec-continue")
+ self.expect("\*stopped,reason=\"breakpoint-hit\"")
+
+ # Detach
+ self.runCmd("-target-detach")
+ self.expect("\^done")
+
+ @skipIfWindows #llvm.org/pr24452: Get lldb-mi tests working on Windows
+ @skipIfFreeBSD # llvm.org/pr22411: Failure presumably due to known thread races
+ @skipIfLinux # cannot attach to process on linux
+ def test_lldbmi_target_attach_pid(self):
+ """Test that 'lldb-mi --interpreter' works for -target-attach <pid>."""
+
+ # Build target executable with unique name
+ exeName = self.testMethodName
+ d = {'EXE': exeName}
+ self.buildProgram("test_attach.cpp", exeName)
+ self.addTearDownCleanup(dictionary=d)
+
+ # Start target process
+ targetProcess = self.spawnSubprocess(os.path.join(os.path.dirname(__file__), exeName));
+ self.addTearDownHook(self.cleanupSubprocesses)
+
+ self.spawnLldbMi(args = None)
+
+ # Set up atatch
+ self.runCmd("-target-attach %d" % targetProcess.pid)
+ self.expect("\^done")
+
+ # Set breakpoint on printf
+ line = line_number('test_attach.cpp', '// BP_i++')
+ self.runCmd("-break-insert -f test_attach.cpp:%d" % line)
+ self.expect("\^done,bkpt={number=\"1\"")
+
+ # Continue to breakpoint
+ self.runCmd("-exec-continue")
+ self.expect("\*stopped,reason=\"breakpoint-hit\"")
+
+ # Detach
+ self.runCmd("-target-detach")
+ self.expect("\^done")
diff --git a/packages/Python/lldbsuite/test/tools/lldb-mi/target/test_attach.cpp b/packages/Python/lldbsuite/test/tools/lldb-mi/target/test_attach.cpp
new file mode 100644
index 0000000..caaf33a
--- /dev/null
+++ b/packages/Python/lldbsuite/test/tools/lldb-mi/target/test_attach.cpp
@@ -0,0 +1,21 @@
+//===-- main.cpp ------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+#include <cstdio>
+
+int
+main(int argc, char const *argv[])
+{
+ int i = 0;
+ for (;;)
+ {
+ i++; // BP_i++
+ }
+ return 0;
+}
OpenPOWER on IntegriCloud