summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/python_api/process
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/python_api/process
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/python_api/process')
-rw-r--r--packages/Python/lldbsuite/test/python_api/process/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/python_api/process/TestProcessAPI.py289
-rw-r--r--packages/Python/lldbsuite/test/python_api/process/io/Makefile6
-rw-r--r--packages/Python/lldbsuite/test/python_api/process/io/TestProcessIO.py206
-rw-r--r--packages/Python/lldbsuite/test/python_api/process/io/main.c19
-rw-r--r--packages/Python/lldbsuite/test/python_api/process/main.cpp31
6 files changed, 556 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/python_api/process/Makefile b/packages/Python/lldbsuite/test/python_api/process/Makefile
new file mode 100644
index 0000000..8a7102e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/process/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/python_api/process/TestProcessAPI.py b/packages/Python/lldbsuite/test/python_api/process/TestProcessAPI.py
new file mode 100644
index 0000000..f312bc8
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/process/TestProcessAPI.py
@@ -0,0 +1,289 @@
+"""
+Test SBProcess APIs, including ReadMemory(), WriteMemory(), and others.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbutil import get_stopped_thread, state_type_to_str
+from lldbsuite.test.lldbtest import *
+
+class ProcessAPITestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break inside main().
+ self.line = line_number("main.cpp", "// Set break point at this line and check variable 'my_char'.")
+
+ @add_test_categories(['pyapi'])
+ def test_read_memory(self):
+ """Test Python SBProcess.ReadMemory() API."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ breakpoint = target.BreakpointCreateByLocation("main.cpp", self.line)
+ self.assertTrue(breakpoint, VALID_BREAKPOINT)
+
+ # Launch the process, and do not stop at the entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+
+ thread = get_stopped_thread(process, lldb.eStopReasonBreakpoint)
+ self.assertTrue(thread.IsValid(), "There should be a thread stopped due to breakpoint")
+ frame = thread.GetFrameAtIndex(0)
+
+ # Get the SBValue for the global variable 'my_char'.
+ val = frame.FindValue("my_char", lldb.eValueTypeVariableGlobal)
+ self.DebugSBValue(val)
+
+ # Due to the typemap magic (see lldb.swig), we pass in 1 to ReadMemory and
+ # expect to get a Python string as the result object!
+ error = lldb.SBError()
+ self.assertFalse(val.TypeIsPointerType())
+ content = process.ReadMemory(val.AddressOf().GetValueAsUnsigned(), 1, error)
+ if not error.Success():
+ self.fail("SBProcess.ReadMemory() failed")
+ if self.TraceOn():
+ print("memory content:", content)
+
+ self.expect(content, "Result from SBProcess.ReadMemory() matches our expected output: 'x'",
+ exe=False,
+ startstr = 'x')
+
+ # Read (char *)my_char_ptr.
+ val = frame.FindValue("my_char_ptr", lldb.eValueTypeVariableGlobal)
+ self.DebugSBValue(val)
+ cstring = process.ReadCStringFromMemory(val.GetValueAsUnsigned(), 256, error)
+ if not error.Success():
+ self.fail("SBProcess.ReadCStringFromMemory() failed")
+ if self.TraceOn():
+ print("cstring read is:", cstring)
+
+ self.expect(cstring, "Result from SBProcess.ReadCStringFromMemory() matches our expected output",
+ exe=False,
+ startstr = 'Does it work?')
+
+ # Get the SBValue for the global variable 'my_cstring'.
+ val = frame.FindValue("my_cstring", lldb.eValueTypeVariableGlobal)
+ self.DebugSBValue(val)
+
+ # Due to the typemap magic (see lldb.swig), we pass in 256 to read at most 256 bytes
+ # from the address, and expect to get a Python string as the result object!
+ self.assertFalse(val.TypeIsPointerType())
+ cstring = process.ReadCStringFromMemory(val.AddressOf().GetValueAsUnsigned(), 256, error)
+ if not error.Success():
+ self.fail("SBProcess.ReadCStringFromMemory() failed")
+ if self.TraceOn():
+ print("cstring read is:", cstring)
+
+ self.expect(cstring, "Result from SBProcess.ReadCStringFromMemory() matches our expected output",
+ exe=False,
+ startstr = 'lldb.SBProcess.ReadCStringFromMemory() works!')
+
+ # Get the SBValue for the global variable 'my_uint32'.
+ val = frame.FindValue("my_uint32", lldb.eValueTypeVariableGlobal)
+ self.DebugSBValue(val)
+
+ # Due to the typemap magic (see lldb.swig), we pass in 4 to read 4 bytes
+ # from the address, and expect to get an int as the result!
+ self.assertFalse(val.TypeIsPointerType())
+ my_uint32 = process.ReadUnsignedFromMemory(val.AddressOf().GetValueAsUnsigned(), 4, error)
+ if not error.Success():
+ self.fail("SBProcess.ReadCStringFromMemory() failed")
+ if self.TraceOn():
+ print("uint32 read is:", my_uint32)
+
+ if my_uint32 != 12345:
+ self.fail("Result from SBProcess.ReadUnsignedFromMemory() does not match our expected output")
+
+ @add_test_categories(['pyapi'])
+ def test_write_memory(self):
+ """Test Python SBProcess.WriteMemory() API."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ breakpoint = target.BreakpointCreateByLocation("main.cpp", self.line)
+ self.assertTrue(breakpoint, VALID_BREAKPOINT)
+
+ # Launch the process, and do not stop at the entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+
+ thread = get_stopped_thread(process, lldb.eStopReasonBreakpoint)
+ self.assertTrue(thread.IsValid(), "There should be a thread stopped due to breakpoint")
+ frame = thread.GetFrameAtIndex(0)
+
+ # Get the SBValue for the global variable 'my_char'.
+ val = frame.FindValue("my_char", lldb.eValueTypeVariableGlobal)
+ self.DebugSBValue(val)
+
+ # If the variable does not have a load address, there's no sense continuing.
+ if not val.GetLocation().startswith("0x"):
+ return
+
+ # OK, let's get the hex location of the variable.
+ location = int(val.GetLocation(), 16)
+
+ # The program logic makes the 'my_char' variable to have memory content as 'x'.
+ # But we want to use the WriteMemory() API to assign 'a' to the variable.
+
+ # Now use WriteMemory() API to write 'a' into the global variable.
+ error = lldb.SBError()
+ result = process.WriteMemory(location, 'a', error)
+ if not error.Success() or result != 1:
+ self.fail("SBProcess.WriteMemory() failed")
+
+ # Read from the memory location. This time it should be 'a'.
+ # Due to the typemap magic (see lldb.swig), we pass in 1 to ReadMemory and
+ # expect to get a Python string as the result object!
+ content = process.ReadMemory(location, 1, error)
+ if not error.Success():
+ self.fail("SBProcess.ReadMemory() failed")
+ if self.TraceOn():
+ print("memory content:", content)
+
+ self.expect(content, "Result from SBProcess.ReadMemory() matches our expected output: 'a'",
+ exe=False,
+ startstr = 'a')
+
+ @add_test_categories(['pyapi'])
+ def test_access_my_int(self):
+ """Test access 'my_int' using Python SBProcess.GetByteOrder() and other APIs."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ breakpoint = target.BreakpointCreateByLocation("main.cpp", self.line)
+ self.assertTrue(breakpoint, VALID_BREAKPOINT)
+
+ # Launch the process, and do not stop at the entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+
+ thread = get_stopped_thread(process, lldb.eStopReasonBreakpoint)
+ self.assertTrue(thread.IsValid(), "There should be a thread stopped due to breakpoint")
+ frame = thread.GetFrameAtIndex(0)
+
+ # Get the SBValue for the global variable 'my_int'.
+ val = frame.FindValue("my_int", lldb.eValueTypeVariableGlobal)
+ self.DebugSBValue(val)
+
+ # If the variable does not have a load address, there's no sense continuing.
+ if not val.GetLocation().startswith("0x"):
+ return
+
+ # OK, let's get the hex location of the variable.
+ location = int(val.GetLocation(), 16)
+
+ # Note that the canonical from of the bytearray is little endian.
+ from lldbsuite.test.lldbutil import int_to_bytearray, bytearray_to_int
+
+ byteSize = val.GetByteSize()
+ bytes = int_to_bytearray(256, byteSize)
+
+ byteOrder = process.GetByteOrder()
+ if byteOrder == lldb.eByteOrderBig:
+ bytes.reverse()
+ elif byteOrder == lldb.eByteOrderLittle:
+ pass
+ else:
+ # Neither big endian nor little endian? Return for now.
+ # Add more logic here if we want to handle other types.
+ return
+
+ # The program logic makes the 'my_int' variable to have int type and value of 0.
+ # But we want to use the WriteMemory() API to assign 256 to the variable.
+
+ # Now use WriteMemory() API to write 256 into the global variable.
+ new_value = str(bytes)
+ error = lldb.SBError()
+ result = process.WriteMemory(location, new_value, error)
+ if not error.Success() or result != byteSize:
+ self.fail("SBProcess.WriteMemory() failed")
+
+ # Make sure that the val we got originally updates itself to notice the change:
+ self.expect(val.GetValue(),
+ "SBProcess.ReadMemory() successfully writes (int)256 to the memory location for 'my_int'",
+ exe=False,
+ startstr = '256')
+
+ # And for grins, get the SBValue for the global variable 'my_int' again, to make sure that also tracks the new value:
+ val = frame.FindValue("my_int", lldb.eValueTypeVariableGlobal)
+ self.expect(val.GetValue(),
+ "SBProcess.ReadMemory() successfully writes (int)256 to the memory location for 'my_int'",
+ exe=False,
+ startstr = '256')
+
+ # Now read the memory content. The bytearray should have (byte)1 as the second element.
+ content = process.ReadMemory(location, byteSize, error)
+ if not error.Success():
+ self.fail("SBProcess.ReadMemory() failed")
+
+ # Use "ascii" as the encoding because each element of 'content' is in the range [0..255].
+ new_bytes = bytearray(content, "ascii")
+
+ # The bytearray_to_int utility function expects a little endian bytearray.
+ if byteOrder == lldb.eByteOrderBig:
+ new_bytes.reverse()
+
+ new_value = bytearray_to_int(new_bytes, byteSize)
+ if new_value != 256:
+ self.fail("Memory content read from 'my_int' does not match (int)256")
+
+ # Dump the memory content....
+ if self.TraceOn():
+ for i in new_bytes:
+ print("byte:", i)
+
+ @add_test_categories(['pyapi'])
+ def test_remote_launch(self):
+ """Test SBProcess.RemoteLaunch() API with a process not in eStateConnected, and it should fail."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ # Launch the process, and do not stop at the entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+
+ if self.TraceOn():
+ print("process state:", state_type_to_str(process.GetState()))
+ self.assertTrue(process.GetState() != lldb.eStateConnected)
+
+ error = lldb.SBError()
+ success = process.RemoteLaunch(None, None, None, None, None, None, 0, False, error)
+ self.assertTrue(not success, "RemoteLaunch() should fail for process state != eStateConnected")
+
+ @add_test_categories(['pyapi'])
+ def test_get_num_supported_hardware_watchpoints(self):
+ """Test SBProcess.GetNumSupportedHardwareWatchpoints() API with a process."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ breakpoint = target.BreakpointCreateByLocation("main.cpp", self.line)
+ self.assertTrue(breakpoint, VALID_BREAKPOINT)
+
+ # Launch the process, and do not stop at the entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+
+ error = lldb.SBError();
+ num = process.GetNumSupportedHardwareWatchpoints(error)
+ if self.TraceOn() and error.Success():
+ print("Number of supported hardware watchpoints: %d" % num)
+
diff --git a/packages/Python/lldbsuite/test/python_api/process/io/Makefile b/packages/Python/lldbsuite/test/python_api/process/io/Makefile
new file mode 100644
index 0000000..5361f2a
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/process/io/Makefile
@@ -0,0 +1,6 @@
+LEVEL = ../../../make
+
+C_SOURCES := main.c
+EXE := process_io
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/python_api/process/io/TestProcessIO.py b/packages/Python/lldbsuite/test/python_api/process/io/TestProcessIO.py
new file mode 100644
index 0000000..2944ee7
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/process/io/TestProcessIO.py
@@ -0,0 +1,206 @@
+"""Test Python APIs for process IO."""
+
+from __future__ import print_function
+
+
+
+import os, sys, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class ProcessIOTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Get the full path to our executable to be debugged.
+ self.exe = os.path.join(os.getcwd(), "process_io")
+ self.local_input_file = os.path.join(os.getcwd(), "input.txt")
+ self.local_output_file = os.path.join(os.getcwd(), "output.txt")
+ self.local_error_file = os.path.join(os.getcwd(), "error.txt")
+
+ self.input_file = os.path.join(self.get_process_working_directory(), "input.txt")
+ self.output_file = os.path.join(self.get_process_working_directory(), "output.txt")
+ self.error_file = os.path.join(self.get_process_working_directory(), "error.txt")
+ self.lines = ["Line 1", "Line 2", "Line 3"]
+
+ @skipIfWindows # stdio manipulation unsupported on Windows
+ @add_test_categories(['pyapi'])
+ def test_stdin_by_api(self):
+ """Exercise SBProcess.PutSTDIN()."""
+ self.build()
+ self.create_target()
+ self.run_process(True)
+ output = self.process.GetSTDOUT(1000)
+ self.check_process_output(output, output)
+
+ @skipIfWindows # stdio manipulation unsupported on Windows
+ @add_test_categories(['pyapi'])
+ def test_stdin_redirection(self):
+ """Exercise SBLaunchInfo::AddOpenFileAction() for STDIN without specifying STDOUT or STDERR."""
+ self.build()
+ self.create_target()
+ self.redirect_stdin()
+ self.run_process(False)
+ output = self.process.GetSTDOUT(1000)
+ self.check_process_output(output, output)
+
+ @skipIfWindows # stdio manipulation unsupported on Windows
+ @add_test_categories(['pyapi'])
+ def test_stdout_redirection(self):
+ """Exercise SBLaunchInfo::AddOpenFileAction() for STDOUT without specifying STDIN or STDERR."""
+ self.build()
+ self.create_target()
+ self.redirect_stdout()
+ self.run_process(True)
+ output = self.read_output_file_and_delete()
+ error = self.process.GetSTDOUT(1000)
+ self.check_process_output(output, error)
+
+ @skipIfWindows # stdio manipulation unsupported on Windows
+ @add_test_categories(['pyapi'])
+ def test_stderr_redirection(self):
+ """Exercise SBLaunchInfo::AddOpenFileAction() for STDERR without specifying STDIN or STDOUT."""
+ self.build()
+ self.create_target()
+ self.redirect_stderr()
+ self.run_process(True)
+ output = self.process.GetSTDOUT(1000)
+ error = self.read_error_file_and_delete()
+ self.check_process_output(output, error)
+
+ @skipIfWindows # stdio manipulation unsupported on Windows
+ @add_test_categories(['pyapi'])
+ def test_stdout_stderr_redirection(self):
+ """Exercise SBLaunchInfo::AddOpenFileAction() for STDOUT and STDERR without redirecting STDIN."""
+ self.build()
+ self.create_target()
+ self.redirect_stdout()
+ self.redirect_stderr()
+ self.run_process(True)
+ output = self.read_output_file_and_delete()
+ error = self.read_error_file_and_delete()
+ self.check_process_output(output, error)
+
+ # target_file - path on local file system or remote file system if running remote
+ # local_file - path on local system
+ def read_file_and_delete(self, target_file, local_file):
+ if lldb.remote_platform:
+ self.runCmd('platform get-file "{remote}" "{local}"'.format(
+ remote=target_file, local=local_file))
+
+ self.assertTrue(os.path.exists(local_file), 'Make sure "{local}" file exists'.format(local=local_file))
+ f = open(local_file, 'r')
+ contents = f.read()
+ f.close()
+
+ #TODO: add 'platform delete-file' file command
+ #if lldb.remote_platform:
+ # self.runCmd('platform delete-file "{remote}"'.format(remote=target_file))
+ os.unlink(local_file)
+ return contents
+
+ def read_output_file_and_delete(self):
+ return self.read_file_and_delete(self.output_file, self.local_output_file)
+
+ def read_error_file_and_delete(self):
+ return self.read_file_and_delete(self.error_file, self.local_error_file)
+
+ def create_target(self):
+ '''Create the target and launch info that will be used by all tests'''
+ self.target = self.dbg.CreateTarget(self.exe)
+ self.launch_info = lldb.SBLaunchInfo([self.exe])
+ self.launch_info.SetWorkingDirectory(self.get_process_working_directory())
+
+ def redirect_stdin(self):
+ '''Redirect STDIN (file descriptor 0) to use our input.txt file
+
+ Make the input.txt file to use when redirecting STDIN, setup a cleanup action
+ to delete the input.txt at the end of the test in case exceptions are thrown,
+ and redirect STDIN in the launch info.'''
+ f = open(self.local_input_file, 'w')
+ for line in self.lines:
+ f.write(line + "\n")
+ f.close()
+
+ if lldb.remote_platform:
+ self.runCmd('platform put-file "{local}" "{remote}"'.format(
+ local=self.local_input_file, remote=self.input_file))
+
+ # This is the function to remove the custom formats in order to have a
+ # clean slate for the next test case.
+ def cleanup():
+ os.unlink(self.local_input_file)
+ #TODO: add 'platform delete-file' file command
+ #if lldb.remote_platform:
+ # self.runCmd('platform delete-file "{remote}"'.format(remote=self.input_file))
+
+ # Execute the cleanup function during test case tear down.
+ self.addTearDownHook(cleanup)
+ self.launch_info.AddOpenFileAction(0, self.input_file, True, False);
+
+ def redirect_stdout(self):
+ '''Redirect STDOUT (file descriptor 1) to use our output.txt file'''
+ self.launch_info.AddOpenFileAction(1, self.output_file, False, True);
+
+ def redirect_stderr(self):
+ '''Redirect STDERR (file descriptor 2) to use our error.txt file'''
+ self.launch_info.AddOpenFileAction(2, self.error_file, False, True);
+
+ def run_process(self, put_stdin):
+ '''Run the process to completion and optionally put lines to STDIN via the API if "put_stdin" is True'''
+ # Set the breakpoints
+ self.breakpoint = self.target.BreakpointCreateBySourceRegex('Set breakpoint here', lldb.SBFileSpec("main.c"))
+ self.assertTrue(self.breakpoint.GetNumLocations() > 0, VALID_BREAKPOINT)
+
+ # Launch the process, and do not stop at the entry point.
+ error = lldb.SBError()
+ # This should launch the process and it should exit by the time we get back
+ # because we have synchronous mode enabled
+ self.process = self.target.Launch (self.launch_info, error)
+
+ self.assertTrue(error.Success(), "Make sure process launched successfully")
+ self.assertTrue(self.process, PROCESS_IS_VALID)
+
+ if self.TraceOn():
+ print("process launched.")
+
+ # Frame #0 should be at our breakpoint.
+ threads = lldbutil.get_threads_stopped_at_breakpoint (self.process, self.breakpoint)
+
+ self.assertTrue(len(threads) == 1)
+ self.thread = threads[0]
+ self.frame = self.thread.frames[0]
+ self.assertTrue(self.frame, "Frame 0 is valid.")
+
+ if self.TraceOn():
+ print("process stopped at breakpoint, sending STDIN via LLDB API.")
+
+ # Write data to stdin via the public API if we were asked to
+ if put_stdin:
+ for line in self.lines:
+ self.process.PutSTDIN(line + "\n")
+
+ # Let process continue so it will exit
+ self.process.Continue()
+ state = self.process.GetState()
+ self.assertTrue(state == lldb.eStateExited, PROCESS_IS_VALID)
+
+ def check_process_output (self, output, error):
+ # Since we launched the process without specifying stdin/out/err,
+ # a pseudo terminal is used for stdout/err, and we are satisfied
+ # once "input line=>1" appears in stdout.
+ # See also main.c.
+ if self.TraceOn():
+ print("output = '%s'" % output)
+ print("error = '%s'" % error)
+
+ for line in self.lines:
+ check_line = 'input line to stdout: %s' % (line)
+ self.assertTrue(check_line in output, "verify stdout line shows up in STDOUT")
+ for line in self.lines:
+ check_line = 'input line to stderr: %s' % (line)
+ self.assertTrue(check_line in error, "verify stderr line shows up in STDERR")
diff --git a/packages/Python/lldbsuite/test/python_api/process/io/main.c b/packages/Python/lldbsuite/test/python_api/process/io/main.c
new file mode 100644
index 0000000..c9a5707
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/process/io/main.c
@@ -0,0 +1,19 @@
+#include <stdio.h>
+
+int main(int argc, char const *argv[]) {
+ printf("Hello world.\n"); // Set breakpoint here
+ char line[100];
+ if (fgets(line, sizeof(line), stdin)) {
+ fprintf(stdout, "input line to stdout: %s", line);
+ fprintf(stderr, "input line to stderr: %s", line);
+ }
+ if (fgets(line, sizeof(line), stdin)) {
+ fprintf(stdout, "input line to stdout: %s", line);
+ fprintf(stderr, "input line to stderr: %s", line);
+ }
+ if (fgets(line, sizeof(line), stdin)) {
+ fprintf(stdout, "input line to stdout: %s", line);
+ fprintf(stderr, "input line to stderr: %s", line);
+ }
+ printf("Exiting now\n");
+}
diff --git a/packages/Python/lldbsuite/test/python_api/process/main.cpp b/packages/Python/lldbsuite/test/python_api/process/main.cpp
new file mode 100644
index 0000000..9610936
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/process/main.cpp
@@ -0,0 +1,31 @@
+//===-- main.c --------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+#include <stdio.h>
+#include <stdint.h>
+
+// This simple program is to test the lldb Python API related to process.
+
+char my_char = 'u';
+char my_cstring[] = "lldb.SBProcess.ReadCStringFromMemory() works!";
+char *my_char_ptr = (char *)"Does it work?";
+uint32_t my_uint32 = 12345;
+int my_int = 0;
+
+int main (int argc, char const *argv[])
+{
+ for (int i = 0; i < 3; ++i) {
+ printf("my_char='%c'\n", my_char);
+ ++my_char;
+ }
+
+ printf("after the loop: my_char='%c'\n", my_char); // 'my_char' should print out as 'x'.
+
+ return 0; // Set break point at this line and check variable 'my_char'.
+ // Use lldb Python API to set memory content for my_int and check the result.
+}
OpenPOWER on IntegriCloud