summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/linux/thread
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/linux/thread
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/linux/thread')
-rw-r--r--packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/TestCreateDuringInstructionStep.py66
-rw-r--r--packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/main.cpp55
3 files changed, 126 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/Makefile b/packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/Makefile
new file mode 100644
index 0000000..67aa166
--- /dev/null
+++ b/packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../../make
+
+CXX_SOURCES := main.cpp
+ENABLE_THREADS := YES
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/TestCreateDuringInstructionStep.py b/packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/TestCreateDuringInstructionStep.py
new file mode 100644
index 0000000..c6d9afb
--- /dev/null
+++ b/packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/TestCreateDuringInstructionStep.py
@@ -0,0 +1,66 @@
+"""
+This tests that we do not lose control of the inferior, while doing an instruction-level step
+over a thread creation instruction.
+"""
+
+from __future__ import print_function
+
+
+
+import os
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class CreateDuringInstructionStepTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+
+ @skipUnlessPlatform(['linux'])
+ @expectedFailureAndroid('llvm.org/pr24737', archs=['arm'])
+ def test_step_inst(self):
+ self.build(dictionary=self.getBuildFlags())
+ exe = os.path.join(os.getcwd(), "a.out")
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target and target.IsValid(), "Target is valid")
+
+ # This should create a breakpoint in the stepping thread.
+ breakpoint = target.BreakpointCreateByName("main")
+ self.assertTrue(breakpoint and breakpoint.IsValid(), "Breakpoint is valid")
+
+ # Run the program.
+ process = target.LaunchSimple(None, None, self.get_process_working_directory())
+ self.assertTrue(process and process.IsValid(), PROCESS_IS_VALID)
+
+ # The stop reason of the thread should be breakpoint.
+ self.assertEqual(process.GetState(), lldb.eStateStopped, PROCESS_STOPPED)
+
+ threads = lldbutil.get_threads_stopped_at_breakpoint(process, breakpoint)
+ self.assertEqual(len(threads), 1, STOPPED_DUE_TO_BREAKPOINT)
+
+ thread = threads[0]
+ self.assertTrue(thread and thread.IsValid(), "Thread is valid")
+
+ # Make sure we see only one threads
+ self.assertEqual(process.GetNumThreads(), 1, 'Number of expected threads and actual threads do not match.')
+
+ # Keep stepping until we see the thread creation
+ while process.GetNumThreads() < 2:
+ thread.StepInstruction(False)
+ self.assertEqual(process.GetState(), lldb.eStateStopped, PROCESS_STOPPED)
+ self.assertEqual(thread.GetStopReason(), lldb.eStopReasonPlanComplete, "Step operation succeeded")
+ if self.TraceOn():
+ self.runCmd("disassemble --pc")
+
+ if self.TraceOn():
+ self.runCmd("thread list")
+
+ # We have successfully caught thread creation. Now just run to completion
+ process.Continue()
+
+ # At this point, the inferior process should have exited.
+ self.assertEqual(process.GetState(), lldb.eStateExited, PROCESS_EXITED)
diff --git a/packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/main.cpp b/packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/main.cpp
new file mode 100644
index 0000000..079e8b1
--- /dev/null
+++ b/packages/Python/lldbsuite/test/linux/thread/create_during_instruction_step/main.cpp
@@ -0,0 +1,55 @@
+//===-- main.cpp ------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+// This file deliberately uses low level linux-specific API for thread creation because:
+// - instruction-stepping over thread creation using higher-level functions was very slow
+// - it was also unreliable due to single-stepping bugs unrelated to this test
+// - some threading libraries do not create or destroy threads when we would expect them to
+
+#include <sched.h>
+
+#include <atomic>
+#include <cstdio>
+
+enum { STACK_SIZE = 0x2000 };
+
+static uint8_t child_stack[STACK_SIZE];
+
+pid_t child_tid;
+
+std::atomic<bool> flag(false);
+
+int thread_main(void *)
+{
+ while (! flag) // Make sure the thread does not exit prematurely
+ ;
+
+ return 0;
+}
+
+int main ()
+{
+ int ret = clone(thread_main,
+ child_stack + STACK_SIZE/2, // Don't care whether the stack grows up or down,
+ // just point to the middle
+ CLONE_CHILD_CLEARTID | CLONE_FILES | CLONE_FS | CLONE_PARENT_SETTID |
+ CLONE_SIGHAND | CLONE_SYSVSEM | CLONE_THREAD | CLONE_VM,
+ nullptr, // thread_main argument
+ &child_tid);
+
+ if (ret == -1)
+ {
+ perror("clone");
+ return 1;
+ }
+
+ flag = true;
+
+ return 0;
+}
OpenPOWER on IntegriCloud