summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/lang/objc/print-obj
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/lang/objc/print-obj
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/lang/objc/print-obj')
-rw-r--r--packages/Python/lldbsuite/test/lang/objc/print-obj/Makefile6
-rw-r--r--packages/Python/lldbsuite/test/lang/objc/print-obj/TestPrintObj.py87
-rw-r--r--packages/Python/lldbsuite/test/lang/objc/print-obj/blocked.m73
3 files changed, 166 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/lang/objc/print-obj/Makefile b/packages/Python/lldbsuite/test/lang/objc/print-obj/Makefile
new file mode 100644
index 0000000..dba1065
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/objc/print-obj/Makefile
@@ -0,0 +1,6 @@
+LEVEL = ../../../make
+
+OBJC_SOURCES := blocked.m
+LDFLAGS = $(CFLAGS) -lobjc -framework Foundation
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/lang/objc/print-obj/TestPrintObj.py b/packages/Python/lldbsuite/test/lang/objc/print-obj/TestPrintObj.py
new file mode 100644
index 0000000..5c52cc0
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/objc/print-obj/TestPrintObj.py
@@ -0,0 +1,87 @@
+"""
+Test "print object" where another thread blocks the print object from making progress.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+
+@skipUnlessDarwin
+class PrintObjTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # My source program.
+ self.source = "blocked.m"
+ # Find the line numbers to break at.
+ self.line = line_number(self.source, '// Set a breakpoint here.')
+
+ def test_print_obj(self):
+ """
+ Test "print object" where another thread blocks the print object from making progress.
+
+ Set a breakpoint on the line in my_pthread_routine. Then switch threads
+ to the main thread, and do print the lock_me object. Since that will
+ try to get the lock already gotten by my_pthread_routime thread, it will
+ have to switch to running all threads, and that should then succeed.
+ """
+ d = {'EXE': 'b.out'}
+ self.build(dictionary=d)
+ self.setTearDownCleanup(dictionary=d)
+ exe = os.path.join(os.getcwd(), 'b.out')
+
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ breakpoint = target.BreakpointCreateByLocation(self.source, self.line)
+ self.assertTrue(breakpoint, VALID_BREAKPOINT)
+ self.runCmd("breakpoint list")
+
+ # Launch the process, and do not stop at the entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+
+ self.runCmd("thread backtrace all")
+
+ # Let's get the current stopped thread. We'd like to switch to the
+ # other thread to issue our 'po lock_me' command.
+ import lldbsuite.test.lldbutil as lldbutil
+ this_thread = lldbutil.get_stopped_thread(process, lldb.eStopReasonBreakpoint)
+ self.assertTrue(this_thread)
+
+ # Find the other thread. The iteration protocol of SBProcess and the
+ # rich comparison methods (__eq__/__ne__) of SBThread come in handy.
+ other_thread = None
+ for t in process:
+ if t != this_thread:
+ other_thread = t
+ break
+
+ # Set the other thread as the selected thread to issue our 'po' command.other
+ self.assertTrue(other_thread)
+ process.SetSelectedThread(other_thread)
+ if self.TraceOn():
+ print("selected thread:" + lldbutil.get_description(other_thread))
+ self.runCmd("thread backtrace")
+
+ # We want to traverse the frame to the one corresponding to blocked.m to
+ # issue our 'po lock_me' command.
+
+ depth = other_thread.GetNumFrames()
+ for i in range(depth):
+ frame = other_thread.GetFrameAtIndex(i)
+ name = frame.GetFunctionName()
+ if name == 'main':
+ other_thread.SetSelectedFrame(i)
+ if self.TraceOn():
+ print("selected frame:" + lldbutil.get_description(frame))
+ break
+
+ self.expect("po lock_me", OBJECT_PRINTED_CORRECTLY,
+ substrs = ['I am pretty special.'])
diff --git a/packages/Python/lldbsuite/test/lang/objc/print-obj/blocked.m b/packages/Python/lldbsuite/test/lang/objc/print-obj/blocked.m
new file mode 100644
index 0000000..ba24975
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/objc/print-obj/blocked.m
@@ -0,0 +1,73 @@
+//===-- blocked.m --------------------------------------------------*- ObjC -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+// This file is for testing running "print object" in a case where another thread
+// blocks the print object from making progress. Set a breakpoint on the line in
+// my_pthread_routine as indicated. Then switch threads to the main thread, and
+// do print the lock_me object. Since that will try to get the lock already gotten
+// by my_pthread_routime thread, it will have to switch to running all threads, and
+// that should then succeed.
+//
+
+#include <Foundation/Foundation.h>
+#include <pthread.h>
+
+static pthread_mutex_t test_mutex;
+
+static void Mutex_Init (void)
+{
+ pthread_mutexattr_t tmp_mutex_attr;
+ pthread_mutexattr_init(&tmp_mutex_attr);
+ pthread_mutex_init(&test_mutex, &tmp_mutex_attr);
+}
+
+@interface LockMe :NSObject
+{
+
+}
+- (NSString *) description;
+@end
+
+@implementation LockMe
+- (NSString *) description
+{
+ printf ("LockMe trying to get the lock.\n");
+ pthread_mutex_lock(&test_mutex);
+ printf ("LockMe got the lock.\n");
+ pthread_mutex_unlock(&test_mutex);
+ return @"I am pretty special.\n";
+}
+@end
+
+void *
+my_pthread_routine (void *data)
+{
+ printf ("my_pthread_routine about to enter.\n");
+ pthread_mutex_lock(&test_mutex);
+ printf ("Releasing Lock.\n"); // Set a breakpoint here.
+ pthread_mutex_unlock(&test_mutex);
+ return NULL;
+}
+
+int
+main ()
+{
+ pthread_attr_t tmp_attr;
+ pthread_attr_init (&tmp_attr);
+ pthread_t my_pthread;
+
+ Mutex_Init ();
+
+ LockMe *lock_me = [[LockMe alloc] init];
+ pthread_create (&my_pthread, &tmp_attr, my_pthread_routine, NULL);
+
+ pthread_join (my_pthread, NULL);
+
+ return 0;
+}
OpenPOWER on IntegriCloud