summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/lang/cpp/wchar_t
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/lang/cpp/wchar_t
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/lang/cpp/wchar_t')
-rw-r--r--packages/Python/lldbsuite/test/lang/cpp/wchar_t/.categories1
-rw-r--r--packages/Python/lldbsuite/test/lang/cpp/wchar_t/Makefile8
-rw-r--r--packages/Python/lldbsuite/test/lang/cpp/wchar_t/TestCxxWCharT.py74
-rw-r--r--packages/Python/lldbsuite/test/lang/cpp/wchar_t/main.cpp35
4 files changed, 118 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/lang/cpp/wchar_t/.categories b/packages/Python/lldbsuite/test/lang/cpp/wchar_t/.categories
new file mode 100644
index 0000000..fe1da02
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/cpp/wchar_t/.categories
@@ -0,0 +1 @@
+dataformatters
diff --git a/packages/Python/lldbsuite/test/lang/cpp/wchar_t/Makefile b/packages/Python/lldbsuite/test/lang/cpp/wchar_t/Makefile
new file mode 100644
index 0000000..fe27980
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/cpp/wchar_t/Makefile
@@ -0,0 +1,8 @@
+LEVEL = ../../../make
+
+CXX_SOURCES := main.cpp
+CFLAGS := -g -O0
+
+clean: OBJECTS+=$(wildcard main.d.*)
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/lang/cpp/wchar_t/TestCxxWCharT.py b/packages/Python/lldbsuite/test/lang/cpp/wchar_t/TestCxxWCharT.py
new file mode 100644
index 0000000..f9cdbca
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/cpp/wchar_t/TestCxxWCharT.py
@@ -0,0 +1,74 @@
+#coding=utf8
+"""
+Test that C++ supports wchar_t correctly.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class CxxWCharTTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break for main.cpp.
+ self.source = 'main.cpp'
+ self.line = line_number(self.source, '// Set break point at this line.')
+
+ def test(self):
+ """Test that C++ supports wchar_t correctly."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+
+ # Create a target by the debugger.
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ # Break on the struct declration statement in main.cpp.
+ lldbutil.run_break_set_by_file_and_line (self, "main.cpp", self.line)
+
+ # Now launch the process, and do not stop at entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+
+ if not process:
+ self.fail("SBTarget.Launch() failed")
+
+ # Check that we correctly report templates on wchar_t
+ self.expect("frame variable foo_y",
+ substrs = ['(Foo<wchar_t>) foo_y = '])
+
+ # Check that we correctly report templates on int
+ self.expect("frame variable foo_x",
+ substrs = ['(Foo<int>) foo_x = '])
+
+ # Check that we correctly report wchar_t
+ self.expect("frame variable foo_y.object",
+ substrs = ['(wchar_t) foo_y.object = '])
+
+ # Check that we correctly report int
+ self.expect("frame variable foo_x.object",
+ substrs = ['(int) foo_x.object = '])
+
+ # Check that we can run expressions that return wchar_t
+ self.expect("expression L'a'",substrs = ['(wchar_t) $',"L'a'"])
+
+ # Mazel Tov if this works!
+ self.expect("frame variable mazeltov",
+ substrs = ['(const wchar_t *) mazeltov = ','L"מזל טוב"'])
+
+ self.expect("frame variable ws_NULL",substrs = ['(wchar_t *) ws_NULL = 0x0'])
+ self.expect("frame variable ws_empty",substrs = [' L""'])
+
+ self.expect("frame variable array",substrs = ['L"Hey, I\'m a super wchar_t string'])
+ self.expect("frame variable array",substrs = ['[0]'], matching=False)
+
+ self.expect('frame variable wchar_zero', substrs=["L'\\0'"])
+ self.expect('expression wchar_zero', substrs=["L'\\0'"])
diff --git a/packages/Python/lldbsuite/test/lang/cpp/wchar_t/main.cpp b/packages/Python/lldbsuite/test/lang/cpp/wchar_t/main.cpp
new file mode 100644
index 0000000..e249c37
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/cpp/wchar_t/main.cpp
@@ -0,0 +1,35 @@
+//===-- main.c --------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+#include <cstring>
+
+template <typename T>
+class Foo
+{
+public:
+ Foo () : object() {}
+ Foo (T x) : object(x) {}
+ T getObject() { return object; }
+private:
+ T object;
+};
+
+
+int main (int argc, char const *argv[])
+{
+ Foo<int> foo_x('a');
+ Foo<wchar_t> foo_y(L'a');
+ const wchar_t *mazeltov = L"מזל טוב";
+ wchar_t *ws_NULL = nullptr;
+ wchar_t *ws_empty = L"";
+ wchar_t array[200], * array_source = L"Hey, I'm a super wchar_t string, éõñž";
+ wchar_t wchar_zero = (wchar_t)0;
+ memcpy(array, array_source, 39 * sizeof(wchar_t));
+ return 0; // Set break point at this line.
+}
OpenPOWER on IntegriCloud