summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/lang/cpp/virtual
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/lang/cpp/virtual
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/lang/cpp/virtual')
-rw-r--r--packages/Python/lldbsuite/test/lang/cpp/virtual/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/lang/cpp/virtual/TestVirtual.py90
-rw-r--r--packages/Python/lldbsuite/test/lang/cpp/virtual/main.cpp113
3 files changed, 208 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/lang/cpp/virtual/Makefile b/packages/Python/lldbsuite/test/lang/cpp/virtual/Makefile
new file mode 100644
index 0000000..314f1cb
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/cpp/virtual/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/lang/cpp/virtual/TestVirtual.py b/packages/Python/lldbsuite/test/lang/cpp/virtual/TestVirtual.py
new file mode 100644
index 0000000..1553a43
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/cpp/virtual/TestVirtual.py
@@ -0,0 +1,90 @@
+"""
+Test C++ virtual function and virtual inheritance.
+"""
+
+from __future__ import print_function
+
+import os, time
+import re
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+def Msg(expr, val):
+ return "'expression %s' matches the output (from compiled code): %s" % (expr, val)
+
+class CppVirtualMadness(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ # This is the pattern by design to match the "my_expr = 'value'" output from
+ # printf() stmts (see main.cpp).
+ pattern = re.compile("^([^=]*) = '([^=]*)'$")
+
+ # Assert message.
+ PRINTF_OUTPUT_GROKKED = "The printf output from compiled code is parsed correctly"
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break for main.cpp.
+ self.source = 'main.cpp'
+ self.line = line_number(self.source, '// Set first breakpoint here.')
+
+ @expectedFailureIcc('llvm.org/pr16808') # lldb does not call the correct virtual function with icc
+ @expectedFailureAll(oslist=['windows'])
+ def test_virtual_madness(self):
+ """Test that expression works correctly with virtual inheritance as well as virtual function."""
+ self.build()
+
+ # Bring the program to the point where we can issue a series of
+ # 'expression' command to compare against the golden output.
+ self.dbg.SetAsync(False)
+
+ # Create a target by the debugger.
+ target = self.dbg.CreateTarget("a.out")
+ self.assertTrue(target, VALID_TARGET)
+
+ # Create the breakpoint inside function 'main'.
+ breakpoint = target.BreakpointCreateByLocation(self.source, self.line)
+ self.assertTrue(breakpoint, VALID_BREAKPOINT)
+
+ # Now launch the process, and do not stop at entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+ self.assertTrue(process, PROCESS_IS_VALID)
+
+ self.assertTrue(process.GetState() == lldb.eStateStopped)
+ thread = lldbutil.get_stopped_thread(process, lldb.eStopReasonBreakpoint)
+ self.assertTrue(thread.IsValid(), "There should be a thread stopped due to breakpoint condition")
+
+ # First, capture the golden output from the program itself from the
+ # series of printf statements.
+ stdout = process.GetSTDOUT(1024)
+
+ self.assertIsNotNone(stdout, "Encountered an error reading the process's output")
+
+ # This golden list contains a list of "my_expr = 'value' pairs extracted
+ # from the golden output.
+ gl = []
+
+ # Scan the golden output line by line, looking for the pattern:
+ #
+ # my_expr = 'value'
+ #
+ for line in stdout.split(os.linesep):
+ match = self.pattern.search(line)
+ if match:
+ my_expr, val = match.group(1), match.group(2)
+ gl.append((my_expr, val))
+ #print("golden list:", gl)
+
+ # Now iterate through the golden list, comparing against the output from
+ # 'expression var'.
+ for my_expr, val in gl:
+
+ self.runCmd("expression %s" % my_expr)
+ output = self.res.GetOutput()
+
+ # The expression output must match the oracle.
+ self.expect(output, Msg(my_expr, val), exe=False,
+ substrs = [val])
diff --git a/packages/Python/lldbsuite/test/lang/cpp/virtual/main.cpp b/packages/Python/lldbsuite/test/lang/cpp/virtual/main.cpp
new file mode 100644
index 0000000..bed1422
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/cpp/virtual/main.cpp
@@ -0,0 +1,113 @@
+#include <stdio.h>
+#include <stdint.h>
+
+class A
+{
+public:
+ A () : m_pad ('c') {}
+
+ virtual ~A () {}
+
+ virtual const char * a()
+ {
+ return __PRETTY_FUNCTION__;
+ }
+
+ virtual const char * b()
+ {
+ return __PRETTY_FUNCTION__;
+ }
+
+ virtual const char * c()
+ {
+ return __PRETTY_FUNCTION__;
+ }
+protected:
+ char m_pad;
+};
+
+class AA
+{
+public:
+ AA () : m_pad('A') {}
+ virtual ~AA () {}
+
+ virtual const char * aa()
+ {
+ return __PRETTY_FUNCTION__;
+ }
+
+protected:
+ char m_pad;
+};
+
+class B : virtual public A, public AA
+{
+public:
+ B () : m_pad ('c') {}
+
+ virtual ~B () {}
+
+ virtual const char * a()
+ {
+ return __PRETTY_FUNCTION__;
+ }
+
+ virtual const char * b()
+ {
+ return __PRETTY_FUNCTION__;
+ }
+protected:
+ char m_pad;
+};
+
+class C : public B, virtual public A
+{
+public:
+ C () : m_pad ('c') {}
+
+ virtual ~C () {}
+
+ virtual const char * a()
+ {
+ return __PRETTY_FUNCTION__;
+ }
+protected:
+ char m_pad;
+};
+
+int main (int argc, char const *argv[], char const *envp[])
+{
+ A *a_as_A = new A();
+ B *b_as_B = new B();
+ A *b_as_A = b_as_B;
+ C *c_as_C = new C();
+ A *c_as_A = c_as_C;
+
+ printf ("a_as_A->a() = '%s'\n", a_as_A->a());
+ printf ("a_as_A->b() = '%s'\n", a_as_A->b());
+ printf ("a_as_A->c() = '%s'\n", a_as_A->c());
+ printf ("b_as_A->a() = '%s'\n", b_as_A->a());
+ printf ("b_as_A->b() = '%s'\n", b_as_A->b());
+ printf ("b_as_A->c() = '%s'\n", b_as_A->c());
+ printf ("b_as_B->aa() = '%s'\n", b_as_B->aa());
+ printf ("c_as_A->a() = '%s'\n", c_as_A->a());
+ printf ("c_as_A->b() = '%s'\n", c_as_A->b());
+ printf ("c_as_A->c() = '%s'\n", c_as_A->c());
+ printf ("c_as_C->aa() = '%s'\n", c_as_C->aa());
+ puts("");// Set first breakpoint here.
+ // then evaluate:
+ // expression a_as_A->a()
+ // expression a_as_A->b()
+ // expression a_as_A->c()
+ // expression b_as_A->a()
+ // expression b_as_A->b()
+ // expression b_as_A->c()
+ // expression b_as_B->aa()
+ // expression c_as_A->a()
+ // expression c_as_A->b()
+ // expression c_as_A->c()
+ // expression c_as_C->aa()
+
+ return 0;
+}
OpenPOWER on IntegriCloud