summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/load_unload
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/functionalities/load_unload
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/load_unload')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/Makefile24
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/TestLoadUnload.py357
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/a.cpp22
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/a.mk23
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/b.cpp21
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/b.mk11
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/c.cpp13
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/c.mk11
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/cmds.txt2
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/d.cpp21
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/d.mk13
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/hidden/Makefile11
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/hidden/d.cpp21
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/main.cpp80
14 files changed, 630 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/Makefile b/packages/Python/lldbsuite/test/functionalities/load_unload/Makefile
new file mode 100644
index 0000000..779745c
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/Makefile
@@ -0,0 +1,24 @@
+LEVEL := ../../make
+
+LIB_PREFIX := loadunload_
+
+LD_EXTRAS := -L. -l$(LIB_PREFIX)d -ldl
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
+
+.PHONY:
+a.out: lib_a lib_b lib_c lib_d hidden_lib_d
+
+lib_%:
+ $(MAKE) -f $*.mk
+
+hidden_lib_d:
+ $(MAKE) -C hidden
+
+clean::
+ $(MAKE) -f a.mk clean
+ $(MAKE) -f b.mk clean
+ $(MAKE) -f c.mk clean
+ $(MAKE) -f d.mk clean
+ $(MAKE) -C hidden clean
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/TestLoadUnload.py b/packages/Python/lldbsuite/test/functionalities/load_unload/TestLoadUnload.py
new file mode 100644
index 0000000..481e7c8
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/TestLoadUnload.py
@@ -0,0 +1,357 @@
+"""
+Test that breakpoint by symbol name works correctly with dynamic libs.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import re
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+@skipIfWindows # Windows doesn't have dlopen and friends, dynamic libraries work differently
+class LoadUnloadTestCase(TestBase):
+
+ def getCategories (self):
+ return ['basic_process']
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break for main.cpp.
+ self.line = line_number('main.cpp',
+ '// Set break point at this line for test_lldb_process_load_and_unload_commands().')
+ self.line_d_function = line_number('d.cpp',
+ '// Find this line number within d_dunction().')
+ if not self.platformIsDarwin():
+ if not lldb.remote_platform and "LD_LIBRARY_PATH" in os.environ:
+ self.runCmd("settings set target.env-vars " + self.dylibPath + "=" + os.environ["LD_LIBRARY_PATH"] + ":" + os.getcwd())
+ else:
+ if lldb.remote_platform:
+ wd = lldb.remote_platform.GetWorkingDirectory()
+ else:
+ wd = os.getcwd()
+ self.runCmd("settings set target.env-vars " + self.dylibPath + "=" + wd)
+
+ def copy_shlibs_to_remote(self, hidden_dir=False):
+ """ Copies the shared libs required by this test suite to remote.
+ Does nothing in case of non-remote platforms.
+ """
+ if lldb.remote_platform:
+ cwd = os.getcwd()
+ shlibs = ['libloadunload_a.so', 'libloadunload_b.so',
+ 'libloadunload_c.so', 'libloadunload_d.so']
+ wd = lldb.remote_platform.GetWorkingDirectory()
+ for f in shlibs:
+ err = lldb.remote_platform.Put(
+ lldb.SBFileSpec(os.path.join(cwd, f)),
+ lldb.SBFileSpec(os.path.join(wd, f)))
+ if err.Fail():
+ raise RuntimeError(
+ "Unable copy '%s' to '%s'.\n>>> %s" %
+ (f, wd, err.GetCString()))
+ if hidden_dir:
+ shlib = 'libloadunload_d.so'
+ hidden_dir = os.path.join(wd, 'hidden')
+ hidden_file = os.path.join(hidden_dir, shlib)
+ err = lldb.remote_platform.MakeDirectory(hidden_dir)
+ if err.Fail():
+ raise RuntimeError(
+ "Unable to create a directory '%s'." % hidden_dir)
+ err = lldb.remote_platform.Put(
+ lldb.SBFileSpec(os.path.join(cwd, 'hidden', shlib)),
+ lldb.SBFileSpec(hidden_file))
+ if err.Fail():
+ raise RuntimeError(
+ "Unable copy 'libloadunload_d.so' to '%s'.\n>>> %s" %
+ (wd, err.GetCString()))
+
+ @skipIfFreeBSD # llvm.org/pr14424 - missing FreeBSD Makefiles/testcase support
+ @not_remote_testsuite_ready
+ @skipIfWindows # Windows doesn't have dlopen and friends, dynamic libraries work differently
+ def test_modules_search_paths(self):
+ """Test target modules list after loading a different copy of the library libd.dylib, and verifies that it works with 'target modules search-paths add'."""
+
+ # Invoke the default build rule.
+ self.build()
+
+ if self.platformIsDarwin():
+ dylibName = 'libloadunload_d.dylib'
+ else:
+ dylibName = 'libloadunload_d.so'
+
+ # The directory with the dynamic library we did not link to.
+ new_dir = os.path.join(os.getcwd(), "hidden")
+
+ old_dylib = os.path.join(os.getcwd(), dylibName)
+ new_dylib = os.path.join(new_dir, dylibName)
+
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ self.expect("target modules list",
+ substrs = [old_dylib])
+ #self.expect("target modules list -t 3",
+ # patterns = ["%s-[^-]*-[^-]*" % self.getArchitecture()])
+ # Add an image search path substitution pair.
+ self.runCmd("target modules search-paths add %s %s" % (os.getcwd(), new_dir))
+
+ self.expect("target modules search-paths list",
+ substrs = [os.getcwd(), new_dir])
+
+ self.expect("target modules search-paths query %s" % os.getcwd(), "Image search path successfully transformed",
+ substrs = [new_dir])
+
+ # Obliterate traces of libd from the old location.
+ os.remove(old_dylib)
+ # Inform (DY)LD_LIBRARY_PATH of the new path, too.
+ env_cmd_string = "settings set target.env-vars " + self.dylibPath + "=" + new_dir
+ if self.TraceOn():
+ print("Set environment to: ", env_cmd_string)
+ self.runCmd(env_cmd_string)
+ self.runCmd("settings show target.env-vars")
+
+ remove_dyld_path_cmd = "settings remove target.env-vars " + self.dylibPath
+ self.addTearDownHook(lambda: self.dbg.HandleCommand(remove_dyld_path_cmd))
+
+ self.runCmd("run")
+
+ self.expect("target modules list", "LLDB successfully locates the relocated dynamic library",
+ substrs = [new_dylib])
+
+ @skipIfFreeBSD # llvm.org/pr14424 - missing FreeBSD Makefiles/testcase support
+ @skipUnlessListedRemote(['android'])
+ @expectedFailureAndroid # wrong source file shows up for hidden library
+ @skipIfWindows # Windows doesn't have dlopen and friends, dynamic libraries work differently
+ def test_dyld_library_path(self):
+ """Test (DY)LD_LIBRARY_PATH after moving libd.dylib, which defines d_function, somewhere else."""
+
+ # Invoke the default build rule.
+ self.build()
+ self.copy_shlibs_to_remote(hidden_dir=True)
+
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ if self.platformIsDarwin():
+ dylibName = 'libloadunload_d.dylib'
+ dsymName = 'libloadunload_d.dylib.dSYM'
+ else:
+ dylibName = 'libloadunload_d.so'
+
+ # The directory to relocate the dynamic library and its debugging info.
+ special_dir = "hidden"
+ if lldb.remote_platform:
+ wd = lldb.remote_platform.GetWorkingDirectory()
+ else:
+ wd = os.getcwd()
+
+ old_dir = wd
+ new_dir = os.path.join(wd, special_dir)
+ old_dylib = os.path.join(old_dir, dylibName)
+
+ remove_dyld_path_cmd = "settings remove target.env-vars " + self.dylibPath
+ self.addTearDownHook(lambda: self.dbg.HandleCommand(remove_dyld_path_cmd))
+
+ # For now we don't track (DY)LD_LIBRARY_PATH, so the old library will be in
+ # the modules list.
+ self.expect("target modules list",
+ substrs = [os.path.basename(old_dylib)],
+ matching=True)
+
+ lldbutil.run_break_set_by_file_and_line (self, "d.cpp", self.line_d_function, num_expected_locations=1)
+ # After run, make sure the non-hidden library is picked up.
+ self.expect("run", substrs=["return", "700"])
+
+ self.runCmd("continue")
+
+ # Add the hidden directory first in the search path.
+ env_cmd_string = ("settings set target.env-vars %s=%s" %
+ (self.dylibPath, new_dir))
+ if not self.platformIsDarwin():
+ env_cmd_string += ":" + wd
+ self.runCmd(env_cmd_string)
+
+ # This time, the hidden library should be picked up.
+ self.expect("run", substrs=["return", "12345"])
+
+ @expectedFailureAll(bugnumber="llvm.org/pr25805", hostoslist=["windows"], compiler="gcc", archs=["i386"], triple='.*-android')
+ @skipIfFreeBSD # llvm.org/pr14424 - missing FreeBSD Makefiles/testcase support
+ @skipUnlessListedRemote(['android'])
+ @skipIfWindows # Windows doesn't have dlopen and friends, dynamic libraries work differently
+ def test_lldb_process_load_and_unload_commands(self):
+ """Test that lldb process load/unload command work correctly."""
+
+ # Invoke the default build rule.
+ self.build()
+ self.copy_shlibs_to_remote()
+
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ # Break at main.cpp before the call to dlopen().
+ # Use lldb's process load command to load the dylib, instead.
+
+ lldbutil.run_break_set_by_file_and_line (self, "main.cpp", self.line, num_expected_locations=1, loc_exact=True)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ if lldb.remote_platform:
+ shlib_dir = lldb.remote_platform.GetWorkingDirectory()
+ else:
+ shlib_dir = self.mydir
+
+ if self.platformIsDarwin():
+ dylibName = 'libloadunload_a.dylib'
+ else:
+ dylibName = 'libloadunload_a.so'
+
+ # Make sure that a_function does not exist at this point.
+ self.expect("image lookup -n a_function", "a_function should not exist yet",
+ error=True, matching=False, patterns = ["1 match found"])
+
+ # Use lldb 'process load' to load the dylib.
+ self.expect("process load %s --install" % dylibName, "%s loaded correctly" % dylibName,
+ patterns = ['Loading "%s".*ok' % dylibName,
+ 'Image [0-9]+ loaded'])
+
+ # Search for and match the "Image ([0-9]+) loaded" pattern.
+ output = self.res.GetOutput()
+ pattern = re.compile("Image ([0-9]+) loaded")
+ for l in output.split(os.linesep):
+ #print("l:", l)
+ match = pattern.search(l)
+ if match:
+ break
+ index = match.group(1)
+
+ # Now we should have an entry for a_function.
+ self.expect("image lookup -n a_function", "a_function should now exist",
+ patterns = ["1 match found .*%s" % dylibName])
+
+ # Use lldb 'process unload' to unload the dylib.
+ self.expect("process unload %s" % index, "%s unloaded correctly" % dylibName,
+ patterns = ["Unloading .* with index %s.*ok" % index])
+
+ self.runCmd("process continue")
+
+ @skipIfFreeBSD # llvm.org/pr14424 - missing FreeBSD Makefiles/testcase support
+ @skipUnlessListedRemote(['android'])
+ def test_load_unload(self):
+ """Test breakpoint by name works correctly with dlopen'ing."""
+
+ # Invoke the default build rule.
+ self.build()
+ self.copy_shlibs_to_remote()
+
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ # Break by function name a_function (not yet loaded).
+ lldbutil.run_break_set_by_symbol (self, "a_function", num_expected_locations=0)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint and at a_function.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'a_function',
+ 'stop reason = breakpoint'])
+
+ # The breakpoint should have a hit count of 1.
+ self.expect("breakpoint list -f", BREAKPOINT_HIT_ONCE,
+ substrs = [' resolved, hit count = 1'])
+
+ # Issue the 'contnue' command. We should stop agaian at a_function.
+ # The stop reason of the thread should be breakpoint and at a_function.
+ self.runCmd("continue")
+
+ # rdar://problem/8508987
+ # The a_function breakpoint should be encountered twice.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'a_function',
+ 'stop reason = breakpoint'])
+
+ # The breakpoint should have a hit count of 2.
+ self.expect("breakpoint list -f", BREAKPOINT_HIT_ONCE,
+ substrs = [' resolved, hit count = 2'])
+
+ @skipIfFreeBSD # llvm.org/pr14424 - missing FreeBSD Makefiles/testcase support
+ @skipUnlessListedRemote(['android'])
+ @skipIfWindows # Windows doesn't have dlopen and friends, dynamic libraries work differently
+ def test_step_over_load (self):
+ """Test stepping over code that loads a shared library works correctly."""
+
+ # Invoke the default build rule.
+ self.build()
+ self.copy_shlibs_to_remote()
+
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ # Break by function name a_function (not yet loaded).
+ lldbutil.run_break_set_by_file_and_line (self, "main.cpp", self.line, num_expected_locations=1, loc_exact=True)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint and at a_function.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ self.runCmd("thread step-over", "Stepping over function that loads library")
+
+ # The stop reason should be step end.
+ self.expect("thread list", "step over succeeded.",
+ substrs = ['stopped',
+ 'stop reason = step over'])
+
+ @skipIfFreeBSD # llvm.org/pr14424 - missing FreeBSD Makefiles/testcase support
+ @skipUnlessListedRemote(['android'])
+ @skipIfWindows # Windows doesn't have dlopen and friends, dynamic libraries work differently
+ @unittest2.expectedFailure("llvm.org/pr25806")
+ def test_static_init_during_load (self):
+ """Test that we can set breakpoints correctly in static initializers"""
+
+ self.build()
+ self.copy_shlibs_to_remote()
+
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ a_init_bp_num = lldbutil.run_break_set_by_symbol(self, "a_init", num_expected_locations=0)
+ b_init_bp_num = lldbutil.run_break_set_by_symbol(self, "b_init", num_expected_locations=0)
+ d_init_bp_num = lldbutil.run_break_set_by_symbol(self, "d_init", num_expected_locations=1)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'd_init',
+ 'stop reason = breakpoint %d' % d_init_bp_num])
+
+ self.runCmd("continue")
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'a_init',
+ 'stop reason = breakpoint %d' % a_init_bp_num])
+ self.expect("thread backtrace",
+ substrs = ['a_init',
+ 'dlopen',
+ 'main'])
+
+ self.runCmd("continue")
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'b_init',
+ 'stop reason = breakpoint %d' % b_init_bp_num])
+ self.expect("thread backtrace",
+ substrs = ['b_init',
+ 'dlopen',
+ 'main'])
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/a.cpp b/packages/Python/lldbsuite/test/functionalities/load_unload/a.cpp
new file mode 100644
index 0000000..235749a
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/a.cpp
@@ -0,0 +1,22 @@
+//===-- a.c -----------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+extern int b_function ();
+
+int a_init()
+{
+ return 234;
+}
+
+int a_global = a_init();
+
+extern "C" int
+a_function ()
+{
+ return b_function ();
+}
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/a.mk b/packages/Python/lldbsuite/test/functionalities/load_unload/a.mk
new file mode 100644
index 0000000..0eb810e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/a.mk
@@ -0,0 +1,23 @@
+LEVEL := ../../make
+
+LIB_PREFIX := loadunload_
+
+CFLAGS_EXTRAS := -fPIC
+LD_EXTRAS := -L. -l$(LIB_PREFIX)b
+
+DYLIB_NAME := $(LIB_PREFIX)a
+DYLIB_CXX_SOURCES := a.cpp
+DYLIB_ONLY := YES
+
+CXXFLAGS += -fPIC
+
+include $(LEVEL)/Makefile.rules
+
+.PHONY:
+$(DYLIB_FILENAME): lib_b
+
+lib_b:
+ "$(MAKE)" -f b.mk
+
+clean::
+ "$(MAKE)" -f b.mk clean
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/b.cpp b/packages/Python/lldbsuite/test/functionalities/load_unload/b.cpp
new file mode 100644
index 0000000..4d38316
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/b.cpp
@@ -0,0 +1,21 @@
+//===-- b.c -----------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+int b_init()
+{
+ return 345;
+}
+
+int b_global = b_init();
+
+int
+b_function ()
+{
+ return 500;
+}
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/b.mk b/packages/Python/lldbsuite/test/functionalities/load_unload/b.mk
new file mode 100644
index 0000000..c1b0877
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/b.mk
@@ -0,0 +1,11 @@
+LEVEL := ../../make
+
+LIB_PREFIX := loadunload_
+
+DYLIB_NAME := $(LIB_PREFIX)b
+DYLIB_CXX_SOURCES := b.cpp
+DYLIB_ONLY := YES
+
+CXXFLAGS += -fPIC
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/c.cpp b/packages/Python/lldbsuite/test/functionalities/load_unload/c.cpp
new file mode 100644
index 0000000..f0dfb4e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/c.cpp
@@ -0,0 +1,13 @@
+//===-- c.c -----------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+extern "C" int
+c_function ()
+{
+ return 600;
+}
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/c.mk b/packages/Python/lldbsuite/test/functionalities/load_unload/c.mk
new file mode 100644
index 0000000..5b5691e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/c.mk
@@ -0,0 +1,11 @@
+LEVEL := ../../make
+
+LIB_PREFIX := loadunload_
+
+DYLIB_NAME := $(LIB_PREFIX)c
+DYLIB_CXX_SOURCES := c.cpp
+DYLIB_ONLY := YES
+
+CXXFLAGS += -fPIC
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/cmds.txt b/packages/Python/lldbsuite/test/functionalities/load_unload/cmds.txt
new file mode 100644
index 0000000..1e4b198
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/cmds.txt
@@ -0,0 +1,2 @@
+breakpoint set -n a_function
+run
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/d.cpp b/packages/Python/lldbsuite/test/functionalities/load_unload/d.cpp
new file mode 100644
index 0000000..55f2a6b
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/d.cpp
@@ -0,0 +1,21 @@
+//===-- c.c -----------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+int d_init()
+{
+ return 123;
+}
+
+int d_global = d_init();
+
+int
+d_function ()
+{ // Find this line number within d_dunction().
+ return 700;
+}
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/d.mk b/packages/Python/lldbsuite/test/functionalities/load_unload/d.mk
new file mode 100644
index 0000000..b6b6eea
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/d.mk
@@ -0,0 +1,13 @@
+LEVEL := ../../make
+
+LIB_PREFIX := loadunload_
+
+DYLIB_EXECUTABLE_PATH := $(CURDIR)
+
+DYLIB_NAME := $(LIB_PREFIX)d
+DYLIB_CXX_SOURCES := d.cpp
+DYLIB_ONLY := YES
+
+CXXFLAGS += -fPIC
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/Makefile b/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/Makefile
new file mode 100644
index 0000000..f84d830
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/Makefile
@@ -0,0 +1,11 @@
+LEVEL := ../../../make
+
+LIB_PREFIX := loadunload_
+
+DYLIB_NAME := $(LIB_PREFIX)d
+DYLIB_CXX_SOURCES := d.cpp
+DYLIB_ONLY := YES
+
+CXXFLAGS += -fPIC
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/d.cpp b/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/d.cpp
new file mode 100644
index 0000000..6a7642c
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/hidden/d.cpp
@@ -0,0 +1,21 @@
+//===-- c.c -----------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+int d_init()
+{
+ return 456;
+}
+
+int d_global = d_init();
+
+int
+d_function ()
+{ // Find this line number within d_dunction().
+ return 12345;
+}
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/main.cpp b/packages/Python/lldbsuite/test/functionalities/load_unload/main.cpp
new file mode 100644
index 0000000..bff9a31
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/main.cpp
@@ -0,0 +1,80 @@
+//===-- main.c --------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+#include <stdio.h>
+#include <dlfcn.h>
+#include <limits.h>
+#include <string.h>
+#include <unistd.h>
+#include <libgen.h>
+#include <stdlib.h>
+
+int
+main (int argc, char const *argv[])
+{
+#if defined (__APPLE__)
+ const char *a_name = "@executable_path/libloadunload_a.dylib";
+ const char *c_name = "@executable_path/libloadunload_c.dylib";
+#else
+ const char *a_name = "libloadunload_a.so";
+ const char *c_name = "libloadunload_c.so";
+#endif
+ void *a_dylib_handle = NULL;
+ void *c_dylib_handle = NULL;
+ int (*a_function) (void);
+
+ a_dylib_handle = dlopen (a_name, RTLD_NOW); // Set break point at this line for test_lldb_process_load_and_unload_commands().
+ if (a_dylib_handle == NULL)
+ {
+ fprintf (stderr, "%s\n", dlerror());
+ exit (1);
+ }
+
+ a_function = (int (*) ()) dlsym (a_dylib_handle, "a_function");
+ if (a_function == NULL)
+ {
+ fprintf (stderr, "%s\n", dlerror());
+ exit (2);
+ }
+ printf ("First time around, got: %d\n", a_function ());
+ dlclose (a_dylib_handle);
+
+ c_dylib_handle = dlopen (c_name, RTLD_NOW);
+ if (c_dylib_handle == NULL)
+ {
+ fprintf (stderr, "%s\n", dlerror());
+ exit (3);
+ }
+ a_function = (int (*) ()) dlsym (c_dylib_handle, "c_function");
+ if (a_function == NULL)
+ {
+ fprintf (stderr, "%s\n", dlerror());
+ exit (4);
+ }
+
+ a_dylib_handle = dlopen (a_name, RTLD_NOW);
+ if (a_dylib_handle == NULL)
+ {
+ fprintf (stderr, "%s\n", dlerror());
+ exit (5);
+ }
+
+ a_function = (int (*) ()) dlsym (a_dylib_handle, "a_function");
+ if (a_function == NULL)
+ {
+ fprintf (stderr, "%s\n", dlerror());
+ exit (6);
+ }
+ printf ("Second time around, got: %d\n", a_function ());
+ dlclose (a_dylib_handle);
+
+ int d_function(void);
+ printf ("d_function returns: %d\n", d_function());
+
+ return 0;
+}
OpenPOWER on IntegriCloud