summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/embedded_interpreter
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/functionalities/embedded_interpreter
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/embedded_interpreter')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/embedded_interpreter/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/functionalities/embedded_interpreter/TestConvenienceVariables.py78
-rw-r--r--packages/Python/lldbsuite/test/functionalities/embedded_interpreter/main.c6
3 files changed, 89 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/embedded_interpreter/Makefile b/packages/Python/lldbsuite/test/functionalities/embedded_interpreter/Makefile
new file mode 100644
index 0000000..0d70f25
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/embedded_interpreter/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+C_SOURCES := main.c
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/embedded_interpreter/TestConvenienceVariables.py b/packages/Python/lldbsuite/test/functionalities/embedded_interpreter/TestConvenienceVariables.py
new file mode 100644
index 0000000..eddaa3c
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/embedded_interpreter/TestConvenienceVariables.py
@@ -0,0 +1,78 @@
+"""Test convenience variables when you drop in from lldb prompt into an embedded interpreter."""
+
+from __future__ import print_function
+
+
+
+import os
+import lldb
+from lldbsuite.test.lldbtest import *
+
+class ConvenienceVariablesCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break on inside main.cpp.
+ self.line = line_number('main.c', 'Hello world.')
+
+ @skipIfFreeBSD # llvm.org/pr17228
+ @skipIfRemote
+ @expectedFailureWindows("llvm.org/pr22274: need a pexpect replacement for windows")
+ def test_with_run_commands(self):
+ """Test convenience variables lldb.debugger, lldb.target, lldb.process, lldb.thread, and lldb.frame."""
+ self.build()
+ import pexpect
+ exe = os.path.join(os.getcwd(), "a.out")
+ prompt = "(lldb) "
+ python_prompt = ">>> "
+
+ # So that the child gets torn down after the test.
+ self.child = pexpect.spawn('%s %s %s' % (lldbtest_config.lldbExec, self.lldbOption, exe))
+ child = self.child
+ # Turn on logging for what the child sends back.
+ if self.TraceOn():
+ child.logfile_read = sys.stdout
+
+ # Set the breakpoint, run the inferior, when it breaks, issue print on
+ # the various convenience variables.
+ child.expect_exact(prompt)
+ child.sendline('breakpoint set -f main.c -l %d' % self.line)
+ child.expect_exact(prompt)
+ child.sendline('run')
+ child.expect_exact("stop reason = breakpoint 1.1")
+ child.expect_exact(prompt)
+ child.sendline('script')
+ child.expect_exact(python_prompt)
+
+ # Set a flag so that we know during teardown time, we need to exit the
+ # Python interpreter, then the lldb interpreter.
+ self.child_in_script_interpreter = True
+
+ child.sendline('print(lldb.debugger)')
+ child.expect_exact(python_prompt)
+ self.expect(child.before, exe=False,
+ patterns = ['Debugger \(instance: .*, id: \d\)'])
+
+ child.sendline('print(lldb.target)')
+ child.expect_exact(python_prompt)
+ self.expect(child.before, exe=False,
+ substrs = ['a.out'])
+
+ child.sendline('print(lldb.process)')
+ child.expect_exact(python_prompt)
+ self.expect(child.before, exe=False,
+ patterns = ['SBProcess: pid = \d+, state = stopped, threads = \d, executable = a.out'])
+
+ child.sendline('print(lldb.thread)')
+ child.expect_exact(python_prompt)
+ # Linux outputs decimal tid and 'name' instead of 'queue'
+ self.expect(child.before, exe=False,
+ patterns = ['thread #1: tid = (0x[0-9a-f]+|[0-9]+), 0x[0-9a-f]+ a\.out`main\(argc=1, argv=0x[0-9a-f]+\) \+ \d+ at main\.c:%d, (name|queue) = \'.+\', stop reason = breakpoint 1\.1' % self.line])
+
+ child.sendline('print(lldb.frame)')
+ child.expect_exact(python_prompt)
+ self.expect(child.before, exe=False,
+ patterns = ['frame #0: 0x[0-9a-f]+ a\.out`main\(argc=1, argv=0x[0-9a-f]+\) \+ \d+ at main\.c:%d' % self.line])
diff --git a/packages/Python/lldbsuite/test/functionalities/embedded_interpreter/main.c b/packages/Python/lldbsuite/test/functionalities/embedded_interpreter/main.c
new file mode 100644
index 0000000..277aa54
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/embedded_interpreter/main.c
@@ -0,0 +1,6 @@
+#include <stdio.h>
+
+int main(int argc, char const *argv[]) {
+ printf("Hello world.\n");
+ return 0;
+}
OpenPOWER on IntegriCloud