summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/functionalities/attach_resume
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/functionalities/attach_resume
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/attach_resume')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/attach_resume/Makefile7
-rw-r--r--packages/Python/lldbsuite/test/functionalities/attach_resume/TestAttachResume.py73
-rw-r--r--packages/Python/lldbsuite/test/functionalities/attach_resume/main.cpp50
3 files changed, 130 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/attach_resume/Makefile b/packages/Python/lldbsuite/test/functionalities/attach_resume/Makefile
new file mode 100644
index 0000000..13d40a1
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/attach_resume/Makefile
@@ -0,0 +1,7 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+ENABLE_THREADS := YES
+EXE := AttachResume
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/attach_resume/TestAttachResume.py b/packages/Python/lldbsuite/test/functionalities/attach_resume/TestAttachResume.py
new file mode 100644
index 0000000..693c0a7
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/attach_resume/TestAttachResume.py
@@ -0,0 +1,73 @@
+"""
+Test process attach/resume.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+exe_name = "AttachResume" # Must match Makefile
+
+class AttachResumeTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @skipIfRemote
+ @expectedFailureFreeBSD('llvm.org/pr19310')
+ @expectedFailureWindows("llvm.org/pr24778")
+ def test_attach_continue_interrupt_detach(self):
+ """Test attach/continue/interrupt/detach"""
+ self.build()
+ self.process_attach_continue_interrupt_detach()
+
+ def process_attach_continue_interrupt_detach(self):
+ """Test attach/continue/interrupt/detach"""
+
+ exe = os.path.join(os.getcwd(), exe_name)
+
+ popen = self.spawnSubprocess(exe)
+ self.addTearDownHook(self.cleanupSubprocesses)
+
+ self.runCmd("process attach -p " + str(popen.pid))
+
+ self.setAsync(True)
+ listener = self.dbg.GetListener()
+
+ self.runCmd("c")
+ lldbutil.expect_state_changes(self, listener, [lldb.eStateRunning])
+
+ self.runCmd("process interrupt")
+ lldbutil.expect_state_changes(self, listener, [lldb.eStateStopped])
+
+ # be sure to continue/interrupt/continue (r204504)
+ self.runCmd("c")
+ lldbutil.expect_state_changes(self, listener, [lldb.eStateRunning])
+
+ self.runCmd("process interrupt")
+ lldbutil.expect_state_changes(self, listener, [lldb.eStateStopped])
+
+ # Second interrupt should have no effect.
+ self.expect("process interrupt", patterns=["Process is not running"], error=True)
+
+ # check that this breakpoint is auto-cleared on detach (r204752)
+ self.runCmd("br set -f main.cpp -l %u" % (line_number('main.cpp', '// Set breakpoint here')))
+
+ self.runCmd("c")
+ lldbutil.expect_state_changes(self, listener, [lldb.eStateRunning, lldb.eStateStopped])
+ self.expect('br list', 'Breakpoint not hit',
+ substrs = ['hit count = 1'])
+
+ # Make sure the breakpoint is not hit again.
+ self.expect("expr debugger_flag = false", substrs=[" = false"]);
+
+ self.runCmd("c")
+ lldbutil.expect_state_changes(self, listener, [lldb.eStateRunning])
+
+ # make sure to detach while in running state (r204759)
+ self.runCmd("detach")
+ lldbutil.expect_state_changes(self, listener, [lldb.eStateDetached])
diff --git a/packages/Python/lldbsuite/test/functionalities/attach_resume/main.cpp b/packages/Python/lldbsuite/test/functionalities/attach_resume/main.cpp
new file mode 100644
index 0000000..7cf3602
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/attach_resume/main.cpp
@@ -0,0 +1,50 @@
+#include <stdio.h>
+#include <fcntl.h>
+
+#include <chrono>
+#include <thread>
+
+#if defined(__linux__)
+#include <sys/prctl.h>
+#endif
+
+volatile bool debugger_flag = true; // The debugger will flip this to false
+
+void *start(void *data)
+{
+ int i;
+ size_t idx = (size_t)data;
+ for (i=0; i<30; i++)
+ {
+ if ( idx == 0 && debugger_flag)
+ std::this_thread::sleep_for(std::chrono::microseconds(1)); // Set breakpoint here
+ std::this_thread::sleep_for(std::chrono::seconds(1));
+ }
+ return 0;
+}
+
+int main(int argc, char const *argv[])
+{
+#if defined(__linux__)
+ // Immediately enable any ptracer so that we can allow the stub attach
+ // operation to succeed. Some Linux kernels are locked down so that
+ // only an ancestor process can be a ptracer of a process. This disables that
+ // restriction. Without it, attach-related stub tests will fail.
+#if defined(PR_SET_PTRACER) && defined(PR_SET_PTRACER_ANY)
+ // For now we execute on best effort basis. If this fails for
+ // some reason, so be it.
+ const int prctl_result = prctl(PR_SET_PTRACER, PR_SET_PTRACER_ANY, 0, 0, 0);
+ static_cast<void> (prctl_result);
+#endif
+#endif
+
+ static const size_t nthreads = 16;
+ std::thread threads[nthreads];
+ size_t i;
+
+ for (i=0; i<nthreads; i++)
+ threads[i] = std::move(std::thread(start, (void*)i));
+
+ for (i=0; i<nthreads; i++)
+ threads[i].join();
+}
OpenPOWER on IntegriCloud