summaryrefslogtreecommitdiffstats
path: root/packages/Python/lldbsuite/test/expression_command/char
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
committerdim <dim@FreeBSD.org>2016-01-06 20:12:03 +0000
commit78b9749c0a4ea980a8b934645da6ae98fcc665e8 (patch)
treedd2a1ddf0476664c2b823409c36cbccd52662ca7 /packages/Python/lldbsuite/test/expression_command/char
parent60cb593f9d55fa5ca7a5372b731f2330345b4b9a (diff)
downloadFreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.zip
FreeBSD-src-78b9749c0a4ea980a8b934645da6ae98fcc665e8.tar.gz
Vendor import of lldb trunk r256945:
https://llvm.org/svn/llvm-project/lldb/trunk@256945
Diffstat (limited to 'packages/Python/lldbsuite/test/expression_command/char')
-rw-r--r--packages/Python/lldbsuite/test/expression_command/char/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/expression_command/char/TestExprsChar.py69
-rw-r--r--packages/Python/lldbsuite/test/expression_command/char/main.cpp10
3 files changed, 84 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/expression_command/char/Makefile b/packages/Python/lldbsuite/test/expression_command/char/Makefile
new file mode 100644
index 0000000..8a7102e
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/char/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/expression_command/char/TestExprsChar.py b/packages/Python/lldbsuite/test/expression_command/char/TestExprsChar.py
new file mode 100644
index 0000000..90e847f
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/char/TestExprsChar.py
@@ -0,0 +1,69 @@
+from __future__ import print_function
+
+
+
+import lldb
+import lldbsuite.test.lldbutil as lldbutil
+from lldbsuite.test.lldbtest import *
+
+class ExprCharTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+
+ self.main_source = "main.cpp"
+ self.main_source_spec = lldb.SBFileSpec (self.main_source)
+ self.exe = os.path.join(os.getcwd(), "a.out")
+
+ def do_test(self, dictionary=None):
+ """These basic expression commands should work as expected."""
+ self.build(dictionary = dictionary)
+
+ target = self.dbg.CreateTarget(self.exe)
+ self.assertTrue(target)
+
+ breakpoint = target.BreakpointCreateBySourceRegex('// Break here', self.main_source_spec)
+ self.assertTrue(breakpoint)
+
+ # Launch the process, and do not stop at the entry point.
+ process = target.LaunchSimple(None, None, self.get_process_working_directory())
+ self.assertTrue(process)
+
+ threads = lldbutil.get_threads_stopped_at_breakpoint(process, breakpoint)
+ self.assertEqual(len(threads), 1)
+
+ frame = threads[0].GetFrameAtIndex(0)
+
+ value = frame.EvaluateExpression("foo(c)")
+ self.assertTrue(value.IsValid())
+ self.assertTrue(value.GetError().Success())
+ self.assertEqual(value.GetValueAsSigned(0), 1)
+
+ value = frame.EvaluateExpression("foo(sc)")
+ self.assertTrue(value.IsValid())
+ self.assertTrue(value.GetError().Success())
+ self.assertEqual(value.GetValueAsSigned(0), 2)
+
+ value = frame.EvaluateExpression("foo(uc)")
+ self.assertTrue(value.IsValid())
+ self.assertTrue(value.GetError().Success())
+ self.assertEqual(value.GetValueAsSigned(0), 3)
+
+ @expectedFailureWindows("llvm.org/pr21765")
+ def test_default_char(self):
+ self.do_test()
+
+ @expectedFailureArch("arm", "llvm.org/pr23069")
+ @expectedFailureArch("aarch64", "llvm.org/pr23069")
+ @expectedFailureWindows("llvm.org/pr21765")
+ def test_signed_char(self):
+ self.do_test(dictionary={'CFLAGS_EXTRAS': '-fsigned-char'})
+
+ @expectedFailurei386("llvm.org/pr23069")
+ @expectedFailurex86_64("llvm.org/pr23069")
+ @expectedFailureWindows("llvm.org/pr21765")
+ def test_unsigned_char(self):
+ self.do_test(dictionary={'CFLAGS_EXTRAS': '-funsigned-char'})
diff --git a/packages/Python/lldbsuite/test/expression_command/char/main.cpp b/packages/Python/lldbsuite/test/expression_command/char/main.cpp
new file mode 100644
index 0000000..c8b0beb
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/char/main.cpp
@@ -0,0 +1,10 @@
+int foo(char c) { return 1; }
+int foo(signed char c) { return 2; }
+int foo(unsigned char c) { return 3; }
+
+int main() {
+ char c = 0;
+ signed char sc = 0;
+ unsigned char uc = 0;
+ return 0; // Break here
+}
OpenPOWER on IntegriCloud