summaryrefslogtreecommitdiffstats
path: root/crypto/heimdal/appl/login/Makefile.am
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>2000-01-09 20:58:00 +0000
committermarkm <markm@FreeBSD.org>2000-01-09 20:58:00 +0000
commit5f68254a360fdb4f3ebc30f6ad6507556425dd0a (patch)
treea96b9cd24173c10bba3fd7e2acf5d68e5bb0773e /crypto/heimdal/appl/login/Makefile.am
parentd88c9767e1793993cc2242ccfb9a8ba002a061c6 (diff)
parent4ecbd6db44d79348bc815f31096e53104f50838b (diff)
downloadFreeBSD-src-5f68254a360fdb4f3ebc30f6ad6507556425dd0a.zip
FreeBSD-src-5f68254a360fdb4f3ebc30f6ad6507556425dd0a.tar.gz
This commit was generated by cvs2svn to compensate for changes in r55682,
which included commits to RCS files with non-trunk default branches.
Diffstat (limited to 'crypto/heimdal/appl/login/Makefile.am')
-rw-r--r--crypto/heimdal/appl/login/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/crypto/heimdal/appl/login/Makefile.am b/crypto/heimdal/appl/login/Makefile.am
new file mode 100644
index 0000000..22b4b62
--- /dev/null
+++ b/crypto/heimdal/appl/login/Makefile.am
@@ -0,0 +1,34 @@
+# $Id: Makefile.am,v 1.16 1999/10/30 08:51:45 assar Exp $
+
+include $(top_srcdir)/Makefile.am.common
+
+INCLUDES += $(INCLUDE_krb4)
+
+bin_PROGRAMS = login
+
+login_SOURCES = \
+ login.c \
+ osfc2.c \
+ read_string.c \
+ utmp_login.c \
+ utmpx_login.c \
+ tty.c \
+ stty_default.c \
+ login_access.c \
+ login_locl.h \
+ login_proto.h \
+ conf.c \
+ shadow.c
+
+LDADD = $(LIB_kafs) \
+ $(top_builddir)/lib/krb5/libkrb5.la \
+ $(LIB_krb4) \
+ $(top_builddir)/lib/des/libdes.la \
+ $(top_builddir)/lib/asn1/libasn1.la \
+ $(LIB_roken) \
+ $(LIB_security)
+
+$(srcdir)/login_protos.h:
+ cd $(srcdir); perl ../../cf/make-proto.pl -o login_protos.h $(login_SOURCES) || rm -f login_protos.h
+
+$(login_OBJECTS): $(srcdir)/login_protos.h
OpenPOWER on IntegriCloud