summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/lib/Target/PowerPC/CMakeLists.txt
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2010-10-11 17:22:16 +0000
committerdim <dim@FreeBSD.org>2010-10-11 17:22:16 +0000
commit1fc65a65fe54635d0e564559ba5a7b8a8a42d4d6 (patch)
treede75a464c5dac7eceb2dbbad8b4d4e1479d79e08 /contrib/llvm/lib/Target/PowerPC/CMakeLists.txt
parentf4f7191cd223adebacee3fad260ed60935be9cb9 (diff)
downloadFreeBSD-src-1fc65a65fe54635d0e564559ba5a7b8a8a42d4d6.zip
FreeBSD-src-1fc65a65fe54635d0e564559ba5a7b8a8a42d4d6.tar.gz
Remove more unneeded files and directories from contrib/llvm. This
still allows us to build tblgen and clang, and further reduces the footprint in the tree. Approved by: rpaulo (mentor)
Diffstat (limited to 'contrib/llvm/lib/Target/PowerPC/CMakeLists.txt')
-rw-r--r--contrib/llvm/lib/Target/PowerPC/CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/contrib/llvm/lib/Target/PowerPC/CMakeLists.txt b/contrib/llvm/lib/Target/PowerPC/CMakeLists.txt
deleted file mode 100644
index 7ffc5eb..0000000
--- a/contrib/llvm/lib/Target/PowerPC/CMakeLists.txt
+++ /dev/null
@@ -1,30 +0,0 @@
-set(LLVM_TARGET_DEFINITIONS PPC.td)
-
-tablegen(PPCGenInstrNames.inc -gen-instr-enums)
-tablegen(PPCGenRegisterNames.inc -gen-register-enums)
-tablegen(PPCGenAsmWriter.inc -gen-asm-writer)
-tablegen(PPCGenCodeEmitter.inc -gen-emitter)
-tablegen(PPCGenRegisterInfo.h.inc -gen-register-desc-header)
-tablegen(PPCGenRegisterInfo.inc -gen-register-desc)
-tablegen(PPCGenInstrInfo.inc -gen-instr-desc)
-tablegen(PPCGenDAGISel.inc -gen-dag-isel)
-tablegen(PPCGenCallingConv.inc -gen-callingconv)
-tablegen(PPCGenSubtarget.inc -gen-subtarget)
-
-add_llvm_target(PowerPCCodeGen
- PPCBranchSelector.cpp
- PPCCodeEmitter.cpp
- PPCHazardRecognizers.cpp
- PPCInstrInfo.cpp
- PPCISelDAGToDAG.cpp
- PPCISelLowering.cpp
- PPCJITInfo.cpp
- PPCMCAsmInfo.cpp
- PPCPredicates.cpp
- PPCRegisterInfo.cpp
- PPCSubtarget.cpp
- PPCTargetMachine.cpp
- PPCSelectionDAGInfo.cpp
- )
-
-target_link_libraries (LLVMPowerPCCodeGen LLVMSelectionDAG)
OpenPOWER on IntegriCloud