summaryrefslogtreecommitdiffstats
path: root/contrib/libxo/tests/Makefile.am
diff options
context:
space:
mode:
authormarcel <marcel@FreeBSD.org>2014-10-23 22:30:14 +0000
committermarcel <marcel@FreeBSD.org>2014-10-23 22:30:14 +0000
commitfefcd296e4716886912a74acd38abba4c94bc340 (patch)
treece8b178967e5d33cbba89d0b2f3d2c2ea45616cb /contrib/libxo/tests/Makefile.am
parentbc4f095bf4554f6047f55bd8d28df41679cade6b (diff)
downloadFreeBSD-src-fefcd296e4716886912a74acd38abba4c94bc340.zip
FreeBSD-src-fefcd296e4716886912a74acd38abba4c94bc340.tar.gz
Import libxo 0.1.4
Obtained from: https://github.com/Juniper/libxo Sponsored by: Juniper Networks, Inc.
Diffstat (limited to 'contrib/libxo/tests/Makefile.am')
-rw-r--r--contrib/libxo/tests/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/contrib/libxo/tests/Makefile.am b/contrib/libxo/tests/Makefile.am
new file mode 100644
index 0000000..c69d511
--- /dev/null
+++ b/contrib/libxo/tests/Makefile.am
@@ -0,0 +1,28 @@
+#
+# Copyright 2014, Juniper Networks, Inc.
+# All rights reserved.
+# This SOFTWARE is licensed under the LICENSE provided in the
+# ../Copyright file. By downloading, installing, copying, or otherwise
+# using the SOFTWARE, you agree to be bound by the terms of that
+# LICENSE.
+
+SUBDIRS=core xo
+
+test tests:
+ @(cur=`pwd` ; for dir in $(SUBDIRS) ; do \
+ cd $$dir ; \
+ $(MAKE) tests ; \
+ cd $$cur ; \
+ done)
+
+accept:
+ @(cur=`pwd` ; for dir in $(SUBDIRS) ; do \
+ cd $$dir ; \
+ $(MAKE) accept ; \
+ cd $$cur ; \
+ done)
+
+valgrind:
+ @echo '## Running the regression tests under Valgrind'
+ @echo '## Go get a cup of coffee it is gonna take a while ...'
+ ${MAKE} VALGRIND='valgrind -q' tests
OpenPOWER on IntegriCloud