summaryrefslogtreecommitdiffstats
path: root/contrib/libstdc++/configure.ac
diff options
context:
space:
mode:
authorkan <kan@FreeBSD.org>2007-05-19 01:25:07 +0000
committerkan <kan@FreeBSD.org>2007-05-19 01:25:07 +0000
commit7865836f4b0f698454c31b4593effcb032c22c1e (patch)
treeea6c2718dc1e45ed535d194df808ef31f0ebac92 /contrib/libstdc++/configure.ac
parent1f9ea4d0a40cca64d60cf4dab152349da7b9dddf (diff)
downloadFreeBSD-src-7865836f4b0f698454c31b4593effcb032c22c1e.zip
FreeBSD-src-7865836f4b0f698454c31b4593effcb032c22c1e.tar.gz
GCC 4.2.0 release C++ standard library and runtime support code.
Diffstat (limited to 'contrib/libstdc++/configure.ac')
-rw-r--r--contrib/libstdc++/configure.ac100
1 files changed, 76 insertions, 24 deletions
diff --git a/contrib/libstdc++/configure.ac b/contrib/libstdc++/configure.ac
index f051ddc..6c00c6b 100644
--- a/contrib/libstdc++/configure.ac
+++ b/contrib/libstdc++/configure.ac
@@ -1,7 +1,6 @@
-# Process this file with autoconf to produce a configure script, like so:
-# aclocal && autoconf && autoheader && automake
+# Process this file with autoreconf to produce a configure script.
-AC_PREREQ(2.57)
+AC_PREREQ(2.59)
AC_INIT(package-unused, version-unused,, libstdc++)
AC_CONFIG_SRCDIR(src/ios.cc)
AC_CONFIG_HEADER(config.h)
@@ -13,11 +12,11 @@ AC_CONFIG_HEADER(config.h)
### am handles this now? ORIGINAL_LD_FOR_MULTILIBS=$LD
# For libtool versioning info, format is CURRENT:REVISION:AGE
-libtool_VERSION=6:3:0
+libtool_VERSION=6:9:0
AC_SUBST(libtool_VERSION)
# Find the rest of the source tree framework.
-GLIBCXX_TOPREL_CONFIGURE
+AM_ENABLE_MULTILIB(, ..)
# Gets build, host, target, *_vendor, *_cpu, *_os, etc.
#
@@ -42,7 +41,24 @@ target_alias=${target_alias-$host_alias}
if test "$build" != "$host"; then
# We are being configured with some form of cross compiler.
GLIBCXX_IS_NATIVE=false
- GCC_NO_EXECUTABLES
+ case "$host","$target" in
+ # Darwin crosses can use the host system's libraries and headers,
+ # because of the fat library support. Of course, it must be the
+ # same version of Darwin on both sides. Allow the user to
+ # just say --target=foo-darwin without a version number to mean
+ # "the version on this system".
+ *-*-darwin*,*-*-darwin*)
+ hostos=`echo $host | sed 's/.*-darwin/darwin/'`
+ targetos=`echo $target | sed 's/.*-darwin/darwin/'`
+ if test $hostos = $targetos -o $targetos = darwin ; then
+ GLIBCXX_IS_NATIVE=true
+ fi
+ ;;
+
+ *)
+ GCC_NO_EXECUTABLES
+ ;;
+ esac
else
GLIBCXX_IS_NATIVE=true
fi
@@ -58,38 +74,36 @@ fi
# no-dependencies: turns off auto dependency generation (just for now)
# -Wall: turns on all automake warnings...
# -Wno-portability: ...except this one, since GNU make is now required.
-AM_INIT_AUTOMAKE([1.7.6 no-define foreign no-dependencies -Wall -Wno-portability])
+AM_INIT_AUTOMAKE([1.9.3 no-define foreign no-dependencies -Wall -Wno-portability -Wno-override])
+AH_TEMPLATE(PACKAGE, [Name of package])
+AH_TEMPLATE(VERSION, [Version number of package])
# Runs configure.host, finds CC, CXX, and assorted other critical bits. Sets
# up critical shell variables.
GLIBCXX_CONFIGURE
-#AC_MSG_NOTICE([====== Starting libtool configuration])
AC_LIBTOOL_DLOPEN
AM_PROG_LIBTOOL
AC_SUBST(enable_shared)
AC_SUBST(enable_static)
-#AC_MSG_NOTICE([====== Finished libtool configuration]) ; sleep 10
# Possibly disable most of the library.
-## XXX Consider skipping unncessary tests altogether in this case, rather
+## TODO: Consider skipping unncessary tests altogether in this case, rather
## than just ignoring the results. Faster /and/ more correct, win win.
GLIBCXX_ENABLE_HOSTED
-# Check for support bits and g++ features that don't require linking.
+# Check for compiler support that doesn't require linking.
GLIBCXX_ENABLE_SJLJ_EXCEPTIONS
GLIBCXX_ENABLE_PCH($is_hosted)
# Enable all the variable C++ runtime options.
-# NB: C_MBCHAR must come early.
GLIBCXX_ENABLE_CSTDIO
GLIBCXX_ENABLE_CLOCALE
GLIBCXX_ENABLE_ALLOCATOR
GLIBCXX_ENABLE_CHEADERS($c_model) dnl c_model from configure.host
-GLIBCXX_ENABLE_C_MBCHAR([yes])
-GLIBCXX_ENABLE_C99([yes])
GLIBCXX_ENABLE_LONG_LONG([yes])
-GLIBCXX_ENABLE_THREADS
+GLIBCXX_ENABLE_WCHAR_T([yes])
+GLIBCXX_ENABLE_C99([yes])
GLIBCXX_ENABLE_CONCEPT_CHECKS([no])
GLIBCXX_ENABLE_DEBUG_FLAGS(["-g3 -O0"])
GLIBCXX_ENABLE_DEBUG([no])
@@ -97,7 +111,9 @@ GLIBCXX_ENABLE_CXX_FLAGS
GLIBCXX_ENABLE_FULLY_DYNAMIC_STRING([no])
# No surprises, no surprises...
-if test $atomicity_dir = cpu/generic ; then
+GLIBCXX_ENABLE_THREADS
+GLIBCXX_ENABLE_ATOMIC_BUILTINS
+if test $atomicity_dir = cpu/generic/atomic_mutex ; then
AC_MSG_WARN([No native atomic operations are provided for this platform.])
if test $target_thread_file = single; then
AC_MSG_WARN([They cannot be faked when thread support is disabled.])
@@ -108,6 +124,7 @@ if test $atomicity_dir = cpu/generic ; then
fi
fi
+GLIBCXX_CHECK_COMPILER_FEATURES
if $GLIBCXX_IS_NATIVE; then
@@ -117,14 +134,13 @@ if $GLIBCXX_IS_NATIVE; then
# Check for available headers.
AC_CHECK_HEADERS([nan.h ieeefp.h endian.h sys/isa_defs.h machine/endian.h \
machine/param.h sys/machine.h fp.h locale.h float.h inttypes.h gconv.h \
- sys/types.h])
+ sys/types.h sys/ipc.h sys/sem.h])
- GLIBCXX_CHECK_COMPILER_FEATURES
GLIBCXX_CHECK_LINKER_FEATURES
GLIBCXX_CHECK_MATH_SUPPORT
GLIBCXX_CHECK_BUILTIN_MATH_SUPPORT
GLIBCXX_CHECK_COMPLEX_MATH_SUPPORT
- GLIBCXX_CHECK_WCHAR_T_SUPPORT
+ GLIBCXX_CHECK_ICONV_SUPPORT
GLIBCXX_CHECK_STDLIB_SUPPORT
# For showmanyc_helper().
@@ -142,6 +158,18 @@ if $GLIBCXX_IS_NATIVE; then
# For LFS support.
GLIBCXX_CHECK_LFS
+ # For C99 support to TR1.
+ GLIBCXX_CHECK_C99_TR1
+
+ # For dev/random and dev/urandom for TR1.
+ GLIBCXX_CHECK_RANDOM_TR1
+
+ # For TLS support.
+ GCC_CHECK_TLS
+
+ # For _Unwind_GetIPInfo.
+ GCC_CHECK_UNWIND_GETIPINFO
+
AC_LC_MESSAGES
AC_TRY_COMPILE(
@@ -182,7 +210,6 @@ else
fi
# Construct crosses by hand, eliminating bits that need ld...
- # GLIBCXX_CHECK_COMPILER_FEATURES
# GLIBCXX_CHECK_BUILTIN_MATH_SUPPORT
# GLIBCXX_CHECK_MATH_SUPPORT
@@ -225,7 +252,7 @@ else
AC_DEFINE(HAVE_S_ISREG)
AC_DEFINE(HAVE_S_IFREG)
else
- m4_include([crossconfig.m4])
+ GLIBCXX_CROSSCONFIG
fi
# At some point, we should differentiate between architectures
@@ -258,24 +285,50 @@ else
AC_DEFINE(HAVE_TANHL)
fi
+ # Assume we have _Unwind_GetIPInfo for cross-compiles.
+ AC_DEFINE(HAVE_GETIPINFO)
+
fi
# This depends on GLIBCXX CHECK_LINKER_FEATURES, but without it assumes no.
GLIBCXX_ENABLE_SYMVERS([yes])
+GLIBCXX_ENABLE_VISIBILITY([yes])
+
+ac_ldbl_compat=no
+case "$target" in
+ powerpc*-*-*gnu* | \
+ sparc*-*-linux* | \
+ s390*-*-linux* | \
+ alpha*-*-linux*)
+ AC_TRY_COMPILE(, [
+#if !defined __LONG_DOUBLE_128__ || (defined(__sparc__) && defined(__arch64__))
+#error no need for long double compatibility
+#endif
+ ], [ac_ldbl_compat=yes], [ac_ldbl_compat=no])
+ if test "$ac_ldbl_compat" = yes; then
+ AC_DEFINE([_GLIBCXX_LONG_DOUBLE_COMPAT],1,
+ [Define if compatibility should be provided for -mlong-double-64.])
+ port_specific_symbol_files="\$(top_srcdir)/config/os/gnu-linux/ldbl-extra.ver"
+ fi
+esac
+GLIBCXX_CONDITIONAL(GLIBCXX_LDBL_COMPAT, test $ac_ldbl_compat = yes)
# This depends on GLIBCXX_ENABLE_SYMVERS and GLIBCXX_IS_NATIVE.
GLIBCXX_CONFIGURE_TESTSUITE
# Propagate the target-specific source directories through the build chain.
-# (Nothing currently uses cpu_include_dir directly; only atomicity_include_dir
-# uses it, and it only gets used in this file.)
ATOMICITY_SRCDIR=config/${atomicity_dir}
ATOMIC_WORD_SRCDIR=config/${atomic_word_dir}
+CPU_DEFINES_SRCDIR=config/${cpu_defines_dir}
OS_INC_SRCDIR=config/${os_include_dir}
+ABI_TWEAKS_SRCDIR=config/${abi_tweaks_dir}
AC_SUBST(ATOMICITY_SRCDIR)
AC_SUBST(ATOMIC_WORD_SRCDIR)
+AC_SUBST(CPU_DEFINES_SRCDIR)
+AC_SUBST(ABI_TWEAKS_SRCDIR)
AC_SUBST(OS_INC_SRCDIR)
+
# Determine cross-compile flags and AM_CONDITIONALs.
#AC_SUBST(GLIBCXX_IS_NATIVE)
#AM_CONDITIONAL(CANADIAN, test $CANADIAN = yes)
@@ -314,7 +367,6 @@ AC_CONFIG_FILES( \
Makefile \
AC_FOREACH([DIR], glibcxx_SUBDIRS, [DIR/Makefile ])
)
-AC_CONFIG_FILES([scripts/check_survey],[chmod +x scripts/check_survey])
AC_CONFIG_FILES([scripts/testsuite_flags],[chmod +x scripts/testsuite_flags])
dnl These commands are run at the end of config.status:
OpenPOWER on IntegriCloud