summaryrefslogtreecommitdiffstats
path: root/contrib/file/python/setup.py
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2016-04-18 07:36:24 +0000
committerdelphij <delphij@FreeBSD.org>2016-04-18 07:36:24 +0000
commit1852c3675cd08e58d07e956f9023f5b3eee5ca3c (patch)
tree7811b5b9831ebf5066c7eae2d213b5e48f66deb7 /contrib/file/python/setup.py
parentcb410646fdaa9c6e3285e1d015ad0095ba9b012b (diff)
parent3c98cb6b19e2270fd5235eb16a8ae98de4fb0b5f (diff)
downloadFreeBSD-src-1852c3675cd08e58d07e956f9023f5b3eee5ca3c.zip
FreeBSD-src-1852c3675cd08e58d07e956f9023f5b3eee5ca3c.tar.gz
MFV r298178:
Update file to 5.26. MFC after: 2 weeks Relnotes: yes
Diffstat (limited to 'contrib/file/python/setup.py')
-rw-r--r--contrib/file/python/setup.py32
1 files changed, 22 insertions, 10 deletions
diff --git a/contrib/file/python/setup.py b/contrib/file/python/setup.py
index 2c3b527..24ae182 100644
--- a/contrib/file/python/setup.py
+++ b/contrib/file/python/setup.py
@@ -1,10 +1,22 @@
-# Python distutils build script for magic extension
-from distutils.core import setup
-
-setup(name = 'Magic file extensions',
- version = '0.2',
- author = 'Reuben Thomas',
- author_email = 'rrt@sc3d.org',
- license = 'BSD',
- description = 'libmagic Python bindings',
- py_modules = ['magic'])
+# coding: utf-8
+
+from __future__ import unicode_literals
+
+from setuptools import setup
+
+
+setup(name='file-magic',
+ version='0.3.0',
+ author='Reuben Thomas, Álvaro Justen',
+ author_email='rrt@sc3d.org, alvarojusten@gmail.com',
+ url='https://github.com/file/file',
+ license='BSD',
+ description='(official) libmagic Python bindings',
+ py_modules=['magic'],
+ test_suite='tests',
+ classifiers = [
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Natural Language :: English',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ])
OpenPOWER on IntegriCloud