summaryrefslogtreecommitdiffstats
path: root/contrib/file/configure.in
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2004-12-28 04:31:47 +0000
committerobrien <obrien@FreeBSD.org>2004-12-28 04:31:47 +0000
commitdf11c7b63d4e785920524068f8f9cbdef5dc08ad (patch)
tree1f6a2b8408267a2849e0e3074601f0e52db5e802 /contrib/file/configure.in
parentbda6cdf5897e5ebed7279aca3ea3387bddcb19b0 (diff)
downloadFreeBSD-src-df11c7b63d4e785920524068f8f9cbdef5dc08ad.zip
FreeBSD-src-df11c7b63d4e785920524068f8f9cbdef5dc08ad.tar.gz
Virgin import of Christos Zoulas's FILE 4.12.
Diffstat (limited to 'contrib/file/configure.in')
-rw-r--r--contrib/file/configure.in40
1 files changed, 34 insertions, 6 deletions
diff --git a/contrib/file/configure.in b/contrib/file/configure.in
index a3b9c5d..a9cd542 100644
--- a/contrib/file/configure.in
+++ b/contrib/file/configure.in
@@ -1,8 +1,9 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(src/file.c)
-AM_INIT_AUTOMAKE(file, 4.10)
-AM_CONFIG_HEADER(config.h)
-AM_MAINTAINER_MODE
+AC_INIT
+AC_CONFIG_SRCDIR([src/file.c])
+AM_INIT_AUTOMAKE(file, 4.12)
+AM_CONFIG_HEADER([config.h])
+dnl AM_MAINTAINER_MODE
AC_MSG_CHECKING(for builtin ELF support)
AC_ARG_ENABLE(elf,
@@ -55,6 +56,24 @@ AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_LIBTOOL
+dnl Templates for autoheader
+AH_TEMPLATE([BUILTIN_ELF],
+ [Use the builtin ELF recognition code])
+AH_TEMPLATE([ELFCORE],
+ [Recognize ELF core files])
+AH_TEMPLATE([HAVE_DAYLIGHT], [])
+AH_TEMPLATE([HAVE_LONG_LONG], [])
+AH_TEMPLATE([HAVE_TM_ISDST], [])
+AH_TEMPLATE([SIZEOF_UINT16_T], [])
+AH_TEMPLATE([SIZEOF_UINT32_T], [])
+AH_TEMPLATE([SIZEOF_UINT64_T], [])
+AH_TEMPLATE([SIZEOF_UINT8_T], [])
+AH_TEMPLATE([int32_t], [])
+AH_TEMPLATE([uint16_t], [])
+AH_TEMPLATE([uint32_t], [])
+AH_TEMPLATE([uint64_t], [])
+AH_TEMPLATE([uint8_t], [])
+
dnl Checks for headers
AC_HEADER_STDC
AC_HEADER_MAJOR
@@ -74,7 +93,15 @@ dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_OFF_T
AC_TYPE_SIZE_T
-AC_STRUCT_ST_RDEV
+AC_DIAGNOSE([obsolete],[AC_STRUCT_ST_RDEV:
+ your code should no longer depend upon `HAVE_ST_RDEV', but
+ `HAVE_STRUCT_STAT_ST_RDEV'. Remove this warning and
+ the `AC_DEFINE' when you adjust the code.])
+AC_CHECK_MEMBERS([struct stat.st_rdev],[AC_DEFINE(HAVE_ST_RDEV, 1,
+ [Define to 1 if your `struct stat' has `st_rdev'.
+ Deprecated, use `HAVE_STRUCT_STAT_ST_RDEV'
+ instead.])])
+
AC_STRUCT_TIMEZONE_DAYLIGHT
AC_SYS_LARGEFILE
AC_MBSTATE_T
@@ -103,4 +130,5 @@ AC_CHECK_FUNCS(mmap strerror strtoul mbrtowc mkstemp getopt_long utimes utime wc
dnl Checks for libraries
AC_CHECK_LIB(z,gzopen)
-AC_OUTPUT(Makefile src/Makefile magic/Makefile doc/Makefile)
+AC_CONFIG_FILES([Makefile src/Makefile magic/Makefile doc/Makefile python/Makefile])
+AC_OUTPUT
OpenPOWER on IntegriCloud