summaryrefslogtreecommitdiffstats
path: root/devel/meta-cvs/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2003-02-28 16:49:54 +0000
committerglewis <glewis@FreeBSD.org>2003-02-28 16:49:54 +0000
commitb9978136ae2070319effb854cf18a9681c88c62d (patch)
treede5866c36e7990ebd3018fe42d7aca1931d10332 /devel/meta-cvs/Makefile
parentb4f70b911253edaa1c8f2e5bf822fb307f1add6d (diff)
downloadFreeBSD-ports-b9978136ae2070319effb854cf18a9681c88c62d.zip
FreeBSD-ports-b9978136ae2070319effb854cf18a9681c88c62d.tar.gz
Add a port of Meta-CVS, a more capable version control system than CVS,
built around CVS. PR: 48258 Submitted by: Johannes Groedem <johs@copyleft.no>
Diffstat (limited to 'devel/meta-cvs/Makefile')
-rw-r--r--devel/meta-cvs/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/meta-cvs/Makefile b/devel/meta-cvs/Makefile
new file mode 100644
index 0000000..c6802fa
--- /dev/null
+++ b/devel/meta-cvs/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: meta-cvs
+# Date created: 13 February 2003
+# Whom: johs
+#
+# $FreeBSD$
+#
+
+PORTNAME= meta-cvs
+PORTVERSION= 1.0.5
+CATEGORIES= devel
+MASTER_SITES= http://users.footprints.net/~kaz/
+DISTNAME= mcvs-${PORTVERSION}
+
+MAINTAINER= johs@copyleft.no
+COMMENT= A more capable version control system than CVS, built around CVS
+
+BUILD_DEPENDS= clisp:${PORTSDIR}/lang/clisp
+
+pre-build:
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
+ ${CP} ${FILESDIR}/build.sh ${WRKSRC}/code
+
+post-install:
+ ${SED} 's:PREFIX:${PREFIX}:g' ${FILESDIR}/mcvs.tmpl > ${WRKDIR}/mcvs
+ ${INSTALL_SCRIPT} ${WRKDIR}/mcvs ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/Meta-CVS-PAPER ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/QUICK-GUIDE ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
OpenPOWER on IntegriCloud